Cannot add to Resources folder

I’ve tried both dragging my file to the side bar and I’ve also tried adding a build step that copies the file and neither way is resulting in anything being added to the Resources folder of my builds. Anyone else having trouble with this?

dragging a file into the side bar will not add it to the resources
depending on the type of file it may just get added to the application in a way you can refer to it as a program constant

not sure how you have the copy file step set up but I use those all the time to copy files into several places including resources

make sure

  • your copy file step is AFTER the BUILD step for which ever target
  • your copy file step is set to BOTH for whether it should run in debug and/or full builds
  • your copy file step DESTINATION is set to Resources Folder
  • and that you have added the files you want copied to the step itself

like this

I usually rename it to something like “CopyFontsToResourceFolder” as a reminder of what it does.