Can run any console application in debug mode (macOS)

I was attempting to run a console application in debug mode but it would not start.

The terminal would open but the IDE would hang for about 30 seconds then it would show this error.

I tried on various versions from 2023r2 back to 2019r1.1 and none of them worked. Desktop and web apps work just fine. Building the console app works as well, just can’t start in debug mode. I could not find any more details in any logs.

Macbook Pro M1 Max, macOS 12.6.2

Any ideas where to start?

Check the DebugFolder property of the build settings, and clear it out if there is anything unusual in there. A nonexistent folder can cause this error.


I don’t see any DebugFolder property, can you point me to where it is?

Sorry, outdated terminology.

Under Build Settings > Shared, check the Destination property under Debug.

Thanks, I tried to set it to a few different things like a clean folder on my desktop, documents and temporary. None of them seemed to make a difference.

Have you done the needful:

  • rebooted
  • tried with another user
  • tried another computer
  • reset the cache
  • removed all plugins?

I had a lot going on so I was trying to avoid a reboot. Not sure what the actual cause was but a reboot fixed it.


1 Like