Built-In methods in new framework not showing "Help"

I have been slowly converting the syntax of one of my existing desktop applications to the new Xojo Framework. One thing that I have noticed is that none of the new methods show any way to access their help page from the contextual menu.

For example (this is oversimplified, but it makes the point):

result = Mid(source, 5)
result = source.Middle(5)

In the source code editor, right click on “Mid” and you are given the contextual menu item to go straight to the Help page for the Mid function. Right click on “Middle”, and you get nothing. As far as I can tell this is universal. None of the new framework methods (AddRow, ResizeTo, etc.) have any way to easily access their help pages. This is a huge regression from the older syntax and I’m hoping that it’s either an oversight, or that it will be fixed in the next release.

Anyone else have the same thoughts?


-bill k

What version of Xojo are you using?

In the 2019 R3.1 IDE I can right click on Middle and contextual menu shows “String.Middle”, click on the menu and I’m shown help for that topic.

That’s using online docs and built in documentation

Xojo 2019 R3.1 on macOS Catalina. Two installs, one on my MBP and the other on an iMac, both have the exact same issue.

Redim myArray(5)

Switching the preference option for “When seeking help:” seems to make no difference.

Right click on Redim and I get the menu item to go to the help page, right click on ResizeTo and nothing (Edit: I do get the generic “Open Language Reference” menu item, but it only opens to the main page). Interestingly the status bar “tooltip” text recognizes the ResizeTo and displays “Integer (newSize As Integer)” when the mouse hovers over the method name.

If you can explain the steps to reproduce the bug, open a ticket in the feedback app. This one can be a bit related: <https://xojo.com/issue/57902>

Sorry I’m not at my Mac to try, I’m on my Windows 10 PC at work.

But I just tried your recent example on my PC and it worked as expected

I agree with Rick, try and explain the steps to reproduce

OK, it’s behaving the exact same way on my Windows install also.

  1. Start a new desktop project
  2. In the Window1 “Open” event place the following:

Dim myArray() As Integer

Redim myArray(20)

This is what I get when I right click on “Redim”:

This is what I see when I right click on “ResizeTo”:

I’ll open up a feedback case, but I just want to make sure that it isn’t me…


-bill k

Same on my mac with ResizeTo, but Middle works if I define source as string:

Please open a feedback case.