Building macOS version on Windows

Last June I used Xojo 2022r1.1 to build a Universal macOS app on a Win 10 PC and was able to extract the App folder from the TAR into a zip file.

Today when i tried the same thing I got an error regarding a missing privilege. The error window is attached.

Any ideas how to fix this ?

Ron Bower
Ellicott City, MD

Windows doesn’t support the linking technology macOS uses. You aren’t supposed to do this. If you untar the output from Xojo on Windows, you break the Mac app and can’t send it to a Mac user. You have to send the tar to Mac for handling.


Why? The tar file contains all the structures and flags macOS needs, extracting it in a PC will get those properties lost and damage the contents.


Thanks to all for the quick replies. It seems I was given bad advice a few years ago.

Strange how it has worked well all this time with no complaints. But, glad to be set straight now.

Ron Bower

I suspect that you had been building 32-bit macOS apps before Xojo was actually using a “framework”. That would have allowed you to do what you are describing.