Build/Run Problem


I have a new program I am working on and it builds just fine but when I try to run the app nothing happens. No window appears or anything. It apparently quits before the main window appears. This happens on both Build and Run within the IDE. I have the build settings targeting this computer (just an Old Dell laptop running Win10).

I recently upgraded from 2018 to the 2020 version (and I just tried the new 2021r1 hoping it would fix the problem but it did not). This is the first app I have created in the 2021 IDE so perhaps it is some kind of setting I am unaware of? (although my other apps build/run fine). Any help would be appreciated.


Did you try to palce some breakpoints, say in App.Open for example, to be able to follow the program run in the debugger ?

No I have not tried that yet. One thing that started the problem was when I tried to drag some small canvas jpegs to the window it would crash Xojo. If I dragged one file at a time it would not crash. I feel like it has something to do with the canvas pix.

I will try some breakpoints. Thanks for the reply.

Also check that you have a window selected under App or it won’t know what to open first:

(Ignore this if you’re opening your own via another method)

What size are they. There exist a max value.

Hey this fixed the problem! It was blank for some reason. many thanks!

1 Like

They are tiny 28x28 pixel jpegs.