Build number will not update

Has anyone seen this and if so, is there a way to fix it?
All of a sudden when I build my app to submit through Transporter, the build number is stuck at an older version despite the settings in Xojo clearly showing that it’s been updated.

I can even confirm in the files Xojo saves out that the number is wrong and inconsistent with what I’ve input.

This is blocking me from uploading a new beta for TestFlight.

Wich nummers are getting stuck? do you set the “Version” (string in app settings) and the version values + increment non release version ?

My guess: the bundle file is open in another process, so the Xojo IDE can’t actually write out the changes when you build.

If you’re using the latest version of Xojo, make sure that Auto Increment Version is turned on. it’s a non-visible number and helps in this situation a lot.

That said, I ran into this very problem just the other day and what I had to do was to remove all of the past uploads that were still present in Transporter. as soon as that was done, it took the version number from the bundle.

keep in mind though that part of that number actually comes from the store. so if you need to update the version number, you need to actually create that version in the store beforehand as well.

the only thing that seems to work is restarting Xojo.
I can see the DistributionSummary file shows the wrong string.

well it’s still happening. I can do one build and then it gets stuck.
I’ve tried restarting transporter. I’ve tried restarting Xojo. Seems I have to restart everything including my Mac before the problem resolves.

has anyone gotten to the root of it?

again I’ll add that the DistributionSummary.plist has the wrong string in it.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.