Browser does not direct to my webapplication (ubuntu/apache/secureport 9001

I decided to set up a new server ubuntu with apache in order to avoid some sequrity ssh issues confronted in the previous server running the app.
Sequrity issues fixed. The only problem is that when i type my domain in browser, it directes to the index.html on var//www/mydomain. I do not know what i am doing wrong… maybe setting the firewal? When i try to enable it in irder to open the secure port 9001, i got a warning that this action may disrupt ssh setting… in that point i said “no”.
I need your experience on that matter to solve this -i beleve- tiny issue… maybe needs somewhere to change aoache configuration files? . Please advise