Blank Screen in Simulator

I hope those of you in the U.S. had a happy Thanksgiving yesterday.

I have a new MacBook Pro. Got latest version of Xcode and Xojo. Ran Xcode. Got command line tools set up (possibly).

Moved project from this computer (the one on which I am now typing) to new computer.

Command-R to run it.

Simulator launches, but nothing shows up. Screen is a very nice white.

Any clues?

Thank you.

Are you able to run a new ios project?


Yes. I did make a new very simple iOS App. That worked.


I don’t ever remember having this issue. But as a new project runs fine we can rule out Xojo not linking to the simulator correctly.

Maybe there is a missing ressource in your existing Xojo project, such as the App Icon, Launch images or an asset (picture) that is used on your Launch Screen.

If your app has Launch images, try removing all and replacing with a LaunchScreen.
If your app has a LaunchScreen, try removing it and running your app.

I thought it might be the icons, so I added all of them. No joy.

Then I checked the image that appears on the starting page. It was missing so I added it back.

Things worked.

I would think this should be reported as a bug. Either we should get an error or, since the missing image files were in exactly the same place relative to the program on the new computer, Xojo should just find them.

Thanks for your assistance.


Just wasted 45 minutes on the same issue. I had moved my project from my MBP to my iMac and broken the link with one of the toolbar images.

App launched in simulator with white screen then immediately crashed. I’d spend 10 minutes making a project and a nice Feedback case but then I’d have wasted almost an hour so… maybe later. But if your previously working project is suddenly just a blank white screen, check your images.