BK Shorts cannot access data

Hello all,

I came across a rather irritating problem today. I’ve been using shorts v1.81 for quite a while. It works great! My problem today, is that I cannot seem to access a certain PostgreSQL database. I have several to choose from, the others work fine. But in this case, I needed to access a database which I restored from a backup of a customers data.

On the customers site (raspberry pi) it works fine. I can also see the data with pgAdmin III and pgAdmin4 V4.

I’ve never had this problem before today. The report appears to connect, but it yields no results.

Nothing has changed, other than I did try pgAdmin4 V6.18 and it gave me an impossible time trying to login. No password changes, all the same as the other two.

So I am hoping someone in the forum can give me a few ideas on what could be the problem.

Finally, I did try with a second backup/restore, but that failed too.

Thanks all!

Just found that if I use a different username/password it does read the data properly.

I don’t understand this…


In what way can’t you access the database? Do you get an error message? Shorts is a drawing / report engine, are you talking about the designer?

Hi Tim,

Sorry, yes I am using the designer.

I can access through pgAdmin of more than 1 version.
I can access through the designer if I use a different login ID and the corresponding password.

No error message on the designer when using either user name/password combination; only get no results with the original user name.


With no error message, I’m curious to know what actually happens. I know we had custom schema reading code for Postgres, but it’s been so long and I don’t have access anymore I’m just hoping to help you notice whatever the cause is.

Is there some way that the login is no good? However I tried with a different app, and that did log in correctly with the combination that appears not to work…

I don’t know what to look for.

I’ve been sick for the last 2 weeks, so maybe foggy. I’m going to try again with the latest version of pgAdmin4-6.18 just in case I reported that result incorrectly,


I can login with pgAdmin 4-6.18 but it says the server version is older than supported. I tried both V9.4 which is what I always use, and Version 13.

Both servers have the same result - says they are unsupported. But again, this is only with the latest pgAdmin version.