Big Sur Safe yet?

Yes, my bad. Xojo 2019R3.2 is the earliest to correctly support compiling under Big Sur.

AFAIK.

Cool. I wasn’t sure if there was a beta that I wasn’t area of.

So… anyone have any critical reservations about upgrading?

If coming from pre-Catalina, you will lose the ability to run 32-bit apps. But that was a change in Catalina, not Bug Sir.

No need for 32 bit apps.
I stopped making them for my clients too.

I’ve been using it as my primary dev OS since I got my M1 Mac Mini a little over a week ago. I like it, honestly. I’ve never been a fan of things like sheet windows (so ugly…), so I suppose I’m more the exception than the rule. From a functionality point of view, I’ve not hit a single snag.

1 Like

I have been trying the various solutions for getting Windows applications to run on my M1 Mac Mini under Big Sur for quick testing.

  • QEMU Vanilla functions well (once you grab the network driver and get that put in), but 1024x768 max resolution
  • ACVM and UTM don’t seem to function as well, and appears to be max 800x600 resolution
  • Parallels Technology Preview will boot and work OK (at 800x600) until I install the Parallels drivers, then it just boot loops or the display doesn’t update unless I resize the window. EDIT: Fixed this by disabling Time Sync in Parallels.
  • CrossOver had issues with network connection
2 Likes

I believe you are talking here in the context of a M1 based mini, whereas I believe the OP is asking about upgrading an Intel mini to BS. So while the points are valid in reference to M1, I don’t think they apply to Intel based machines which (I think) can still do the same virtualization options as pre-Big Sur installations.

While that may be true, they did not specify that. Even if this information isn’t relevant to them, it may be for others participating here, or to them in the future, and is not off-topic in the currently defined context.

1 Like

He didn’t mention in the first message of the thread, but later clarified he was getting prompts to upgrade to BS. That to me implies he is on an Intel machine.

Your point is also taken; but I was trying to qualify by saying it applies to M1 machines in particular and not BS in the more general sense. Again, for the sake of other readers since it is not really relevant to the OP.

FWIW, Anthony’s research was a valuable contribution I liked to know.

4 Likes

BS is running fine on my MBP Pro 16", but I was lucky that I had a backup and some time ;-). Everything worked after the update from Catalina but I had a few issues. The fingerprint scan only worked for logins from time-to-time … unlocking with the Apple Watch didn’t work at all and the search didn’t work properly either (so T2 issues and search issues sounded to me like some en-/decryption issues, so something more severe than just not being able to use this more or less useless “features”).

I didn’t find anything related to it on the forums so when I finally had time, I made a clean re-install and migrated from my external Carbon-Copy-Clone. Since then everything is working properly. And since then the fans turn on less frequently then after the Catalina/BS upgrade. So if you can afford some time, I would suggest a clean install.

And! After upgrading your Xojo licenses will be gone, there a few threads on the forum about this :wink: . Not a big deal, but you should be aware of it.

1 Like

I ended up doing what I always do, and I jumped in.
Everything is working well with regard to my customer projects and Xojo itself.

AppWrapper is doing something odd but I can still wrap my apps so I’ll survive.

2 Likes

What is it doing?

1 Like

Sadly, it’s awful for me.
I am experiencing frequent freezes on my Retina iMac. Sometimes out of the blue, often when changing between running apps. They can last between a few seconds and more than a minute, and a few times a day the system will not recover and restart or shut down.
Kernel panic reports mention different watchdog processes as the possible cause.

The usual cleanups did not help. Maybe a clean system install would, but currently I shy that solution as long as I don’t find confirmation on its success.

Is it still possible to do hardware checks? Yup, here it is: https://support.apple.com/en-us/HT202731. I’d recommend to do this first. If you have a hardware problem then the wonderful reinstalling won’t help.

1 Like

Sam,
When I build and the script starts up AppWrapper, it launches my app (which is not normal) and then carries out its work.
It quickly reports that it failed “check the logs.:.”

But then I get an email from Apple that it’s successfully notarized.

It’s a bit anxiety inducing. But it works.

That is odd and I am sorry that App Wrapper is misbehaving for you. If I may, can we either take this to a separate thread on the forum or continue off forum to avoid filling up this thread.

The next time you wrap and it does this, please select “Help” on the menubar and then “Contact Ohanaware”. This will generate an e-mail to me and include the log, and in AW4 you can select other information to include also. Which I can then take a look at and see I can spot anything.

Sam, I’ll give it a try this am and keep you in the loop outside of this thread.

But for sake of the thread, I am not complaining about your product in any way. I use it every single day, and it saves me a ton of time. Even with this little glitch it’s still doing its job. I can’t say enough good things about AppWrapper.

3 Likes

Thanks Chris.
If I hear that App Wrapper is misbehaving, I want to investigate and see if I can figure out what’s going on. At the end of the day, I do make mistakes and I do get things wrong.

I am pleased to hear how much it has benefited you and I hope that some of the stuff I have in the works will also help you.

1 Like
Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.