Basic problem with Windows install

I am compiling a small app for use on Windows XP. The compiler output is the .exe file and 4 DLLs. The documentation is a little vague but suggests you can zip these, decompress them on Windows, and run. When I do that I get an error:

“The procedure entry point ConvertLenghtToIPV4Mask could not be located in the dynamic link library IPHLPAPI.DLL”

I dismiss that and get the same one more time, then the app launch quits. I tried making an installer with INNO, the result is the same. First time through this process so its probably something really basic, but what?

Check out

Hmm… that’s too bad. Many continue to run on the most recent stable version of Windows, that being XPSP3.

Unfortunately also, that does not seem to be the problem. I was able to compile with 2015r2.4 and get exactly the same error.

Did you make sure to copy all the folders that are produced next to the exe file ?

4 DLLs sounds a suspiciously low number.

There are no folders there?
Is MSVCRT there?

@Jon Fitch , can you compile and run a simple application on the XP machine; or does it happen with any application? I am not sure IPHLPAPI.DLL is part of the Xojo framework.

The msvcrt is there, along with vccorlib, vcruntime, and XojoFramework, all in a folder. This is simple application. I did not check the include all in the build options as you aren’t supposed to need that if VC++ redist is installed (it is).

I tried again with 2015R2.4, uninstalled and reinstalled several times, expecting a different result - some say this is the definition of madness. On the third attempt, it worked. No idea why. Anybody know what the IPHLPAPI.DLL is?

Looks like it’s part of Windows.

The VC 2015 Redistributables are required if you use Xojo 2016r1 or newer

That said it definitely seems there’s “something” not right with your XP machine
I’ve never had issues like this even with newer Xojo versions
Updated XP to SP3
Installed the redistributables and things just worked

IPHLPAPI.DLL has a dependancy on 72 other windows DLLs, I read yesterday. (One of them is msvrct)

This is 99% likely to be down to a library you are including, an ActiveX you reference, or an API you are calling.
ConvertLenghtToIPV4Mask is not included in the IPHLPAPI.DLL which ships with XP.
What you need to work out is ‘what is calling IPHLPAPI.DLL’?


I installed VirtualBox / Windows XP on this week’s Monday. I add to update it to SP III and I was able to run my applications.

Even 2015r1 (with crash): I was able to print to pdf the App entry in the Navigator (but a click elsewhere crashed).

The last IDE working version in Windows XP is… Xojo2013r41Setup.exe (according to the documentation). I downloaded it yesterday (but not get time to use it…)

FTR: I was not able to find a SP III iso file, so I searched in my archives CDs and find a copy of it from a CD. I’ve copied the folder to the shared folder and run the SP III update on my original XP. Since then, each time I connect to the internet, Windows XP download the tons of needed updates…

And, the screen shots I’ve made (under the MacBook Pro’s El Capitan) are Retina :-}

I just removed the 2015r1 IDE from the Windows XP VirtualBox machine and installed Xojo2013r41.

Works fine.

At launch time, I get an advertisement about a new version (2016r4.1) and asked if I want to update (I said No !).

I never had the opportunity to say how I love this reminder / information.

BTW, for the VirtualBox users: if you have updated to the current version, you certainly will enjoy the Christmas image at boot time !

[quote=305160:@Jon Fitch]

Anybody know what the IPHLPAPI.DLL is?[/quote]

IPHLPAPI.dll is a Windows system file installed by Windows and is part of Windows. I have it in my Win7 and Win10. Do not have a WinXP to check but since it is system then it should be there.

File Description is:- IP Helper API

The error
“The procedure entry point ConvertLenghtToIPV4Mask could not be located in the dynamic link library IPHLPAPI.DLL”
means IPHLPAPI.DLL is present and found in the computer/WinXP, but this (WinXP) version of IPHLPAPI.DLL does not have the procedure “ConvertLenghtToIPV4Mask” .

I think whatever (in your program) that is calling this procedure is probably not meant to work in WinXP.

You can download DLL Export Viewer from NirSoft to see what functions/procedures are available in any of the DLLs.

Scroll to the bottom of page for the download.

I found the data for last Xojo IDE for Windows XP here:

[quote=305145:@Jon Fitch]

Hmm… that’s too bad. Many continue to run on the most recent stable version of Windows, that being XPSP3.[/quote]

Microsoft stopped supporting it. And as far as I know all programming languages have dropped support for XP.
Now if you can run an older version of Xojo to compile your app, that might be an option.

Not exactly. The latest VS2015, although will not run in WinXP, it can still be used to write apps that target WinXP.

“ConvertLenghtToIPV4Mask” is misspelled. If this isn’t just a typo in the forum post then it might be the problem.

When connected to the internet (I think) Microsoft send this message (something like “WIndows XP support ended on 2014…”).

That said, I found convenient to be able to run a Windows in my MacBook Pro *. I will try to update this Windows XP to Windows 10 in the coming days.

  • Incredible how many typos / bugs I found while running Windows XP (in less than a week).