Baffled by "Can't find a type with this name"

Hi! I was having trouble testing a new “Chilkat” plugin I’m developing, so I decided to
do a walkthrough of installing and using an existing 3rd party plugin. I had the same trouble,
so I then decided to try to use the pre-installed Oracle plugin.

I do this:

1) Start Xojo
2) Create a new desktop project
3) Create an "Open" event for the default Window1
4) Add this line of code [b]"Dim db as OracleDatabase"[/b].
	Note that Xojo's auto-complete fills in the word "Oracle" and when TAB is pressed, I see the valid choices.
	So Xojo seems to know about the type.
5) I run the code (which should do nothing), but I get this error for the Dim statement:  
	[b]"Can't find a type with this name"[/b]

Am I missing something simple? I’m thoroughly baffled up to this point…

No…I think it is more that XOJO knows the “word” not the type… Don’t you have to have the Oracle database plugin installed, licensed and activated?

My XOJO install knows those “words”, but I know for a fact that I don’t have any of the oracle requirements installed.

Thanks Dave! My question wasn’t really about Oracle specifically, but for any plugin. For example, I downloaded one of the Demo plugins from Einhugur, and get the same error. I get the same behavior w/ the plugin I’m developing – Xojo can recognize the name, but then fails with that error when I try to run.

but did you INSTALL it in the proper directory etc?

Yes. And I can see Xojo loading the plugins at startup…

And restart Xojo?

Yep. Restarted. (I can see the plugins listed while Xojo loads)

Here’s what I see in Xojo:

just did that in windows 7 in a clean VM
copied the two mbs plugins in
started xojo 2015r4
wrote your code
hit run
no issue
not sure what else to say

I notice you are using the IDE on Windows. Is it possible that you have closed the Xojo IDE project windows, but left the IDE running as a systray item? Opening Xojo again will simply reconnect to the running app and will not load the plugins again.

Thanks everybody, I really appreciate it. On a fresh Windows 10 computer it works. On my main development system, it’s a no-go. Maybe Wayne is correct… I did see Xojo loading the plugins as it starts though (because the names of the plugins are briefly displayed when Xojo starts).

I did upgrade from Xojo2015r2.4 to Xojo2015r4 recently. I’m going to try a reboot to see if that solves it. (Now I’m starting to sound like a newbie thinking a reboot is the magic bullet… :wink:

Sometimes that’s the solution though. I had a weird issue with Finder/Favorites that got fixed by restarting recently.

Exit Xojo (find that trayitem and exit)
Clear caches

No dice on the reboot. I’m going to uninstall Xojo completely, then re-install, and then re-copy the plugin to where it should be. This is very strange…

The complete uinstall/re-install (of Xojo2015r4) worked. Thanks to everyone for their extreme patience. :slight_smile:

I’m having the same exact problem described here with Xojo 2017 R3, 2017 R2.1, and 2015 R2.4, with Einhugur’s eCryptIt Engine 13.1.6 on Windows 10 x64.

Reinstalling Xojo and rebooting did not solve it. Any other ideas?

Is it a 64bit compatible plugin?

I don’t have much experience with plugins. Some ideas:

  • Does the plugin show in Xojo - About - Loaded Plugins?
  • is the plugin the latest version available?

I read that someone had some problems and installed the plugin again from the source. Maybe the plugin got corrupt somehow (for that post).

Yes, it is.
Update: Installing the slightly older eCryptIt Engine 13.1.0 works on all three installs of Xojo.

For right now, I’m fine with this. But would still like to find a solution.

If it is on Windows then dont install the e-CryptIt Engine - Legacy part. That one never makes sense on windows and only contains old Mac encodings like macBinary, Applesingle, BinHex, etc, things that do not belong on Windows. (and for 99% of people it does not belong on mac either in the year 2017).

So thats one thing I can hint to you on the issue you have. If it will solve the case for you or not I do not know.

Turns out that I didn’t include the #TypeLib.xojo_plugin the first time. Now it’s working.