Avoiding accidental quit from the IDE

Feedback Case Number: 66270

feedback://showreport?report_id=66270

This one just bit me again.

If I’m running a debug app from the IDE, and quit from it using Cmd-Q, then occasionally the IDE is at the front and quits without warning. This is extremely annoying as it takes (me) > 10 minutes to restart and run my app:

a. Launching IDE: 1:53
b. Opening my project: 6:04
c. Preparing plugins: 3:55
d. Compile and run (890 items): 2:18

Total 10:15 on a top-of-the-line i9 MacBook Pro with 64GB RAM. By the time everything is back to debugging status I have forgotten what I was doing.

Please can we have a “Are you sure you want to quit the IDE?” alert when the IDE quits with all open projects already saved. This could also be optional via the preferences.

6 Likes

I’ve done this too.

A “The Debugger is running. Are you sure you want to quit Xojo?” alert would be awesome.

I agree with your request, however, your numbers seem really slow to me:

I have a top-of-the-line core i9 Macbook Pro, and my results are quite a bit different than yours:
a. Launching IDE: 34s
b. Opening my project: 25s
c. Preparing plugins:0s (preparing plugins only happens on first run of IDE)
d. Compile and run (250+ items): 35s
Total: 1.5 minutes compared to your 10.25 minutes.

This is with 2019R1.1 and about 1/2 of the MBS plugins installed.

What’s different?

  • IDE version?
  • project size?
  • pre-unzipping plugins?
  • some caching problem on your mac?
  • optimization settings for compile?

As a workaround, reassign the key for Quit through Preferences?

(I haven’t tried this.)

Repeating tests with Xojo 2021 R2.1:
a. Launching IDE: 23s
b. Opening my project: 28s
c. Preparing plugins:0s (preparing plugins only happens on first run of IDE)
d. Compile and run (250+ items): N/A (my app won’t compile in this version yet)

So I don’t think it’s the version of Xojo which matters.

If we focus simply on step (A) : Launching IDE - it’s taking 4.9x as long on your machine than mine. The only thing I can think of would be a different set of plugins, or some other problem, such as antivirus software mucking things up?

OK, you are right about the “prepare plugins”. I had noted that since I just added a plugin. However, the 10+ minutes doesn’t include that.

I have no anti-virus software running. I’m using 2021r2.1. I do switch off Turbo mode whenever running Xojo since it’s the only software that makes my fans howl. With it switched off, the computer fans are largely silent. I will try the same experiment with Turbo mode on. I do not have any optimization settings other than the default, and that would only affect compile time on builds.

I have c. 50 plugins. Mostly assorted MBS and Einhugur plugins. I can only think this is the issue. I will try temporarily removing them all and see what transpires.

lots of plugins are known to slow down xojo
also lots of not-up-to-date plugins slow down xojo even more.

All of my plugins are recent.

The main issue I have is loading the project (6+ minutes). It’s saved in text format suitable for Git. I wonder if that might be the issue.

I will run some tests when I have a chance.

Your project: 890 items, Text, loads in 364s.
My project: 250 ish items, a mix of Text and XML formats, loads in 25s.
Your project is 3.5x as big as mine but takes 14.5x as long to load.

That’s probably quite relevant.

Also, if you want to try pre-unzipping your plugins, I wrote a shell script to do it (semi) automatically: Unzipped Plugins - still possible? - #51 by Mike_D

Edit to add: if you have the 2019 16" MBP, there is apparently a problem where using an external monitor causes the GPU to run hot: 16" is HOT & NOISY with an external monitor! :( | MacRumors Forums

How do you count the number of items in a project?

When you compile, it shows up in the progress bar. I don’t know exactly what is being counted.
Example:

I have three 27" monitors attached. However, Xojo is the only app that consistently makes my fans howl. Since (AFAIK) the GPU is not used in the IDE (apart perhaps in the LLVM code generation and linking phase) I don’t think it’s an issue here.

Thanks you Mike!

Older Xojo versions (perhaps named otherwise) used to have a warning for that. It eventually disappeared without warning in one release; a feature request has already been done years ago. Have you not found it before creating your case?

Well, I let Turbo mode running, and apart from fan noise, it had a bigger effect than I thought:

IDE Launch: 1:28
Open project: 3:37
Compile & run: 1:23
TOTAL: 6:28

Better than 10:15 for sure. I was sure Turbo mode only made a few percent difference, not 37%. I guess I’ll learn to live with fan noise.

I did note that the majority of IDE launch time was dealing with plugins. I will try the unzipping trick.

I searched but didn’t find it. I guess my keywords weren’t up to the task.

Well, if the other one wasn’t already closed, they’ll probably just close either one as duplicate :wink:

Or both :stuck_out_tongue_winking_eye:

Could be. Would be very unpleasant, though.
I can’t think of a good reason to avoid showing a warning in such cases.

Right, but since the GPUs and CPUs share common fans, if your GPU is running warm, it can make the system appear more sensitive to the CPU usage. It would be intersting if you did a test with Turbo mode but without any external monitors just for fun. (I’m using the 15" 2019 MBP with Vega 20, which I think doesn’t have the same CPU heat issues that the 16" model does).

Also, curious to see if the unzipping plugins helps, as your startup is still quite a bit slower than mine.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.