AutoDiscovery Error 22 - Solved

Hello all,
Can anyone tell me what error 22 is, when using auto discovery? The docs do not have this error code in them, so far as I could tell. Also, does anyone know how to fix this?

Thank you,

Go to the SocketCore online page. Just underneath the error code table, you’ll find some help to figure out what this code means depending on the platform your application is running on.

If it’s running on OS X, this page from MBS’ NUG archive may help you. Look at Charles Yeomans post:

[quote]"Probably it’s

#define EINVAL 22 /* Invalid argument */

from /usr/include/sys/errno.h .

You might see this if you call TCPSocket.Write on a socket that has
been disconnected.

Note that calling TCPSocket.Write on a socket that has never been
connected will not result in an error. Instead it appears that the
data is buffered until a connection is established."

Charles Yeomans [/quote]
The TCPSocket class, like EasyUDPSocket, is based on SocketCore.

Thanks for the reply Eric,
I came across the invalid argument via google, but that was clear as mud. After some trial and error (I could repeat the error 22) I found that the problem was initiated when the user tried to join the group when it is already a member. Some additional code to check that first stopped the problem.

Thanks again,

FYI, rather than changing the conversation title to add “Solved”, you can just click the “check mark” in the top right of the post that answers your question. This will mark the conversation as “answered” and the answer will appear in the original post.

OK, Thanks Paul.