Archive releases .deb installer

I have Linux Mint 64 bit running quite nicely here and wanted to try Xojo on this syetm.

My latest licensed version is 2016r11 so I went to the archived versions on the download section of the site. It seems the .deb package is unavailable/not found on the download server.

Is there a way to get this ?

The .rpm and .tgz bundles dont install so I cant use those.


[quote=302334:@Stephen Thomas]Is there a way to get this ?
They dont exist
tgz and rpm’s are all there is

tgz’s should just extract where ever you want - they really dont “install”

Fair enough. I saw .deb in all the download options for the archive releases. Maybe it could be removed ?

Regarding the .tgz files, is it a case of just running the program from wherever it is unpacked ?

Will see about getting the .deb listings removed

And yes once you unpack it you can execute it from there

In some versions, there is a .deb entry, but nothing downloads.

I also noticed a bad download IDE (around 30MB). I tried to downaload it many times to get the same wrong file. I didn’t had time to report it, then forgot about it (till I read this entry.

Xojo: I do not know the real storage hierarchy (the download folder), but a single check for the size will be enough. If not ask me and I will check and report the answer.

I’m not aware of any of them being corrupt or small. It would be helpful if you could tell us which one you’re having trouble with, just in case it’s something else causing the problem.

I search (where I archived them).

First HD was the good one.

I found this:

Name: Xojo2014r31Setup.exe
Size: 45.3MB

Xojo2014r32Setup.exe is 202.5MB while Xojo2014r3Setup.exe is 201.2MB.

I do not tried to execute it and I will not do that. I changed it extention to .txt and get an eye on its internal. Read the warning below.

BTW: I suggest you to NOT RUN THAT .exe FILE and remove it asap, replace it with a brand new one, tested. Then it is up to you to search or not what this file can be / what happened.

Doh ! After reading my last sentence, it can be read as… directive ? Do not think that, think … “to show caution”, a bit extreme, but caution.

There’s nothing wrong with our archived copy of Xojo2014r31Setup.exe- looks like you just need to re-download it, as it sounds like you got an incomplete download.

Hi Travis: good news.

I already tried to download it two or three times before I forget it.

I’m on El Capitan right now, the download goes on and the reported size is 193MB (that size can be good), but at 100KB/S it will take time. (remaining time; 24minutes)

Sorry if I was too cautionous.

For a first attempt on a slow connexion, it goes well: 18 minutes to go (70MB uploaded and continuing).

Download complete. Size: 202 465 208 Bytes (202.5MB on disk).

[quote=302350:@Norman Palardy]Will see about getting the .deb listings removed

And yes once you unpack it you can execute it from there[/quote]

I got it running in the end. I used the .tgz download, unpacked it, changed the permissions on the (Or something like that), then copied the entire folder to the /usr folder.

There are a couple of complaints in the terminal window if I launch it that way, but it still seems to work.

Just as a follow up, when launching from the terminal window using ‘./Xojo’, the following messages appear :

Gtk-Message: Failed to load module “atk-bridge” cannot open shared object file: No such file or directory[RB] Unable to load plugin OraclePlugin.xojo_plugin
Could not load libWebKit
Could not load libGtkHTML
(Xojo:4087): Gtk-WARNING **: gtk_menu_attach_to_widget(): menu already attached to GtkImageMenuItem

Doing a few checks regarding installed packages, I have the following confirmed as installed :


In package manager I cant find anything referring to libGtkHTML or anything even remotely similar.

If anyone has any suggestions of which further packages need to be installed to reduce these messages, I’d appreciate it.

This system is Linux Mint (64bit) Sarah (18.0).