Application has stopped working

My latest app build runs fine on Mac and Linux but is getting fairly consistent ‘XYZ has stopped working’ messages on both Windows XP and 7, both running under Parallels. Some of it seems to be related to the Einhugur encryption routines, but it is more common than I would prefer.

There seems to be no forum post about it. Web searches indicate it was a major issue with Vista and older apps, malware or device drivers, but I am fully up to date. They suggest turning off Data Execution Prevention (DEP), but it is already off in Windows 7.

Have others had this problem? Is there an easy solution?

Does it have any OSX Declares in it? If so are they protected by #IF TARGET ?

I made this mistake myself… I forget to wrap one declare… and it would bomb under Win7… but run fine in OSX

Thanks Norman for pointing that out to me :slight_smile:

Thanks Dave. No OSX Declares in this code. I found it was a bug in the EncodeHex() under Windows. I have a number of old PC programs giving the same error (not Xojo apps) that gave the same error and was curious. I assume this was the problem most people found with Vista/7 trying to clean up 30 years of bad coding.

I’m getting the same problem when I close my application window. This has only appeared recently. I’ve even gone to the effort of using Arbed Win to compare the current version and an older version where the problem was not occurring and copying the changes over.

It is still occurring on my latest version, but not on my Parallels setup, only on my workplaces real Win7 PCs.

Any ideas? Nothing in my app has really changed dramatically.