Applescript can't find the file by it's Get Info path

set file_path = “smb://192.168.0.24/d/myfolder/myfile.pdf” --path copied from Get Info window for the actual file listed in a Finder window.

make new mail attachment with properties {file name:file_path as alias} at after last paragraph – This gets a file not found error.

The file is accessible manually in the Finder. What did I do wrong and what do I need to do to get it to work?

Use the hfs path starting with the mounted volume name.

file alias ?
I’d try POSIX PATH

make new mail attachment with properties {file name:file_path as POSIX PATH} at after last paragraph

Kem,
I tried the hfs path before and that got the same problem.

Norman,
I tried POSIX PATH and that gets:

Syntax Error
Expected class name but found property.

…with POXIX PATH hilited as the cause.

I’m using Mavericks still, in case that matters.

I tried POSIX PATH with both the smb and hfs paths and get the same syntax error message.

Thanks for the advice, but I’m still stuck.

What HFS path are you using?

For HFS, I used

set file_path to “192.168.0.24:d:myfolder:myfile.pdf”.

Note: My original post shows “set file_path =” but I actually used “set file_path to”…

The remote drive is mounted as “192.168.0.24”, or at least that’s what the Finder is calling it.

Why not copy the file to a local temporary folder before trying to attach it?
It would have the added benefit of attaching and sending faster (because Mail wouldn’t have to reach out)

Confirm that. In AppleScript, try

tell application "Finder"
	name of every disk whose local volume is false
end tell

and see what it gives you.