Apple Certificate Help! Please

I had my Mac worked on by apple and they wiped it (which I knew they would).
Since then I’ve reinstalled and restored everything but my development certificates are messed up, and I can’t quite figure out why.

When I say messed up, the problem I’m having is with App Wrapper complaining of missing private keys.

In Keychain I can see that I have a development and distribution profile that include private keys.

In Xcode I can see that I have these, but there are others listed with an X “missing private key”. Is it possible to remove these? I don’t see them in my keychain so I don’t know where they are.

in the Apple Developer Portal I thought I could revoke them all and rebuild. There is no option to revoke them though. I tried to make new ones, but now I just have extras in the developer portal, my keychains look correct but I’m still having issues.

If anyone has a clear set of steps that I can go through to clean this up, it would be appreciated.
If someone wants to get paid for an hour or two of “consulting” to help me out, I’d gladly shell out! I’ve lost too much time on this (again).

1 Like

I’ve sent you an email.

For those who don’t already know how to get in touch with me, I do provide Xojo consulting services. Send me a direct message or visit for other ways to contact me.