App will not run in Ubuntu 64Bit

I have created an app and built it for linux. It will not run. I have made the file executable in the permissions. So I’m picking this is a 32bit program trying to run on a 64bit OS. Does anyone know how to get it to run.

sudo apt-get install ia32-libs

EDIT: For clarification, run a terminal command ‘sudu apt-get install ia32-libs’ to install the 32-bit libraries.

I get the following message

Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
lib32z1 lib32ncurses5 lib32bz2-1.0

E: Package ‘ia32-libs’ has no installation candidate

So I installed them. And it still doesn’t work.

maybe package is named “ia32-libs-multiarch”?

You must activate multiarch before installing ia32-libs:

sudo dpkg --add-architecture i386

sudo apt-get update

sudo apt-get install ia32-libs-multiarch

More information:

I tried this same thing on Ubuntu 14.04 64bit and it still will not install or can find that package.

Is there a solution to this?

I copy another message that I wrote on another thread:

It seems than Ubuntu isn’t going to mantain the compatibility with 32 bits libraries on his 64 bits systems (on Debian it works fine).

There is a workaround for accomplish this (tested on Ubuntu Desktop 14.04 64 bits fresh installation):

Insert this line on /etc/apt/sources.list:

deb raring main restricted universe multiverse

Then you can install ia32-libs:

sudo apt-get update sudo apt-get install ia32-libs

This works, but It’s not an ideal solution because you are mixing in your sources.list repositories of different versions of Ubuntu, so use it at your own risk. Personally I decided some time ago to change all my Xojo apps from Ubuntu to Debian, so I recommend.

Welcome to even more obscure suffering while we wait for 64-bit Linux builds. Check out for inexpensive, easy to configure 32 bit VPSs.

just tried to use a xojo app on latest ubuntu 14.10 64 bit linux… no chance. anything new on this? if xojo apps can’t be used on ubuntu, than xojo inc should update their documentation/ requirements.

Have you installed the required libraries ?

sudo dpkg --add-architecture i386

sudo apt-get update

sudo apt-get install ia32-libs-multiarch

sudo apt-get update

worked but not :

sudo apt-get install ia32-libs

this is what i get :

Strange. So apparently ia-32-libs is not available ?

I guess we can just hope that Xojo Linux 64 bit gets here sooner than later. From what I understand, Xojo is already working on it.

As I mentioned previously, many of the latest 64bit distributions are completely abandoning any type of 32bit support.

For now, you will need to stay with an older distribution, move to a distribution that still supports 32bit under 64bit or 32bit native, or wait until Xojo releases 64bit Linux support.

If you are releasing commercial software for Linux, you would need to apply these same limits to your customers.

would be nice to hear a statement by xojo and yes I now have to inform my customers not to use my apps on 64bit linux

If you are not restricted by your customers that the app actually BE 64bit, you might wish to take a look at Statifier or (commercial) Magic Ermine.

My problem with a few of our larger licensees is that they do not accept apps if they are not clean 64bit. If this is not a limitation with your customers (i.e.: they just need the app to run properly), then either of those solutions may help for the short term.

Thank you Tim for your advice but these solutions do not really sound trustworthy. It would be another layer or middle-tier, causing more opportunities for issues and support incidents, no thanks.

As long as 32Bit Apps can be run without hassle my customer does not care if 64Bit or 32BIt. That’s the problem.

Take a look at Statifier, Tomas. This method of encapsulating the app is similar to the way crackers used to break copy protection on old Commodore C=64 systems: Start the game, let it get past the copy protection check and start, take a memory snapshot and save to a new floppy. The resulting game then played fine without destroying your C=64’s 1541 disk drive with those half-track or forced bad sector resets.

This is sort of what Statifier does - starts your app, gives it a chance to load all of the necessary libraries, and then creates a new, self-contained runtime image. No external dependencies at all.