App will not launch in Simulator with 2015 r2

I just downloaded r2 and tried to test my app in the Simulator and found it will not launch when the target is for an iPad. iPhone 6 worked okay, but it fails if I choose iPad Air or iPad Retina. Error message is:

Compilation of “app name” failed.
An error occurred when attempting to launch the application.

This app works fine with 2015 r1. Any ideas where to look to find out why it no longer runs on iPad Simulator?

Thanks.

Got to the directory your project is in and delete the .app in the folder. It seems that sometimes the app gets orphaned but deleting it and then running again seems to clear up the issue for me.

Took a look and there is not a .app in the folder so nothing to delete.

I did find that it was the launch image assets and/or icon assets. The only thing I tried before running my test was to convert the launch images and icons to the assets. This seems to be causing the failure for the iPad launch.

Any ideas why it would work for the iPhone Simulator but fail for iPad Simulator?