App.Name Syntax Error !?


I’m a bit puzzled here, I’ve reloaded my project in Xojo that I’ve just built 5 minutes ago, and now whenever I’m trying to launch it or build it I get this error:

App.Name - Syntax Error

Any idea what this could be ?


With your project open, check the Build Settings properties in the IDE for the platform you’re running on and make sure that the “App Name” entry is valid.

Yes the App Name is valid. No matter what I change I get this error.

But no panic, I’ve reloaded a backup I did 15 minutes prior the issue and it is working fine again…

But doing some experiments, it seems I have to change the App Builds Names AND the Xojo project file name (with Save As) at the same time or else I end up having this error. Very strange. I’ve also noticed in the project XML file a new ‘Name As String’ Property on the App which was not there in the working project.

Another ‘esoteric’ issue ; - )


I had this issue after encrypting some parts of my application, and then updating to a newer version of Xojo. I fixed the issue by decrypting and re-internalizing the encrypted portions of the app. It seems that my case and your’s are a bit different, but there may be a common factor that escapes me at the moment.

Perhaps there is some commonality with your case?

… getting old and repeating myself. And I cannot edit my post either.

This usually amounts to “something in the app class set up results in a syntax error” like you’ve tried to set a default on a property that is a class instance or something similar
Or there’s some ambiguity like a property named App or something like that

I did not tried to set a default on a property or something. The only thing I recall is having changed the app build names and rebuild my project, save the project, renamed the project file name manually.

At that point it was working, I could run/build the project.

I had to quit Xojo for some other reasons.

Then I reloaded the project and tried to build it, at this point I got the error. Then I re-saved this project (because the build number is auto-incrementing). And here, I’ve noticed that the XML project file was 8k bigger than the one I’ve just loaded which is odd having modified nothing inside the project.

Then I examined the XML files (I always backup copies of project files) and I noticed the newly saved one had this ‘Name As String’ Property on the App (that I did not added myself) and some oddities like some properties having a default value in the item declaration and not in the item source (while the default value was in both before).

I have run into this issue as well.

I have a project in RB2012r3 that I now try run in Xojo 2015.1 but I get the App.Name syntax message.

I can not find the problem.

@XojoInc: Do you want me to report it on Feedback and attach the project?

Thin I found my problem:

I’m using localized constants, prefixed with # in the App-class fields: LaunchMessage and DisconnectMessage.

Just came in that same error : App.Name syntax error !!!
I’ve just change some code to remove calls to Graphics due to xojo 2018r3
no other error but this one.
I’ve looked at the properties of the build settings, seems ok (and I did not change anything there)
what can it be ???

Edit: it’s a desktop app that compiles ok with 2018r2

just found that strange error :
Build settings/Shared/Description : this field was empty. fill it with anything and the compile is OK !!!

is it a feature or a bug ?

of course if you make an empty project, with nothing in the description field, it compiles like a charm …
so problem solved, but is it really ?

We’d love a copy of this and a feedback report so we can dig into what the issue is.

not sure it will help because today I just removed the content of the description property, and it compiles with no error …

You’re right. In this case, the project probably wouldn’t help. It’s good that it’s working for you now!

I just ran into this error for the first time today.
An extremely simple app: a window with a listbox and two buttons, and one method. (sort of an interest calculator) None of the ideas above worked to make this compile. (It compiled fine for 32 bit, but not for 64). It is a very old app last updated in Xojo(or Real) 2012 using Linux. I am updating it with Xojo2019r1.1.
But, I did notice one other thing. After the first time I tried to compile it for 64, causing it to fail, the code editor became unusably slow. I mean copy, count to ten; click, count to 25; paste, go get a cup of coffee.
I finally started a new project and copied the code over from the old one and it works fine.

Linux Mint, Xojo 2019r1.1