Apache Error 720002 help

Hello all.
I am trying to set up a new web server for testing. It uses windows 7 64bit.
I downloaded and installed PostgreSQL without issue. It has been set up and works properly. Then using its stack builder I downloaded and installed Apache. I was able to confirm that Apache is running.

The app is a CGI, I placed it and its folders in the cgi-bin folder, tried to connect but nothing. I looked at the apache logs and I see recurring entries of

couldn’t create child process: 720002: axcysconnex.cgi
AH01223: couldn’t spawn child process: C:/Program Files (x86)/PostgreSQL/EnterpriseDB-ApacheHTTPD/apache/cgi-bin/axcysconnex/axcysconnex.cgi

Can anyone advise what might be wrong/missing and where to get it?
Thank you,

It’s not a good idea to put your website folder, or CGI, under C:/Program Files. I’m more used to linux servers, so I can’t say for sure, but I think it’s probably the reason why the CGI can’t start (this folder/directory is closely monitored and activity restricted by Windows). Try configuring Apache to use another location for CGI scripts.

Thank you for your reply Renaud.

I tried reinstalling and put into the root. I get the same error with a different path:

[cgi:error] [pid 5680:tid 1612] (OS 2)The system cannot find the file specified. : [client] couldn’t create child process: 720002: axcysconnex.cgi
[cgi:error] [pid 5680:tid 1612] (OS 2)The system cannot find the file specified. : [client] AH01223: couldn’t spawn child process: C:/xampp/cgi-bin/axcysconnex.cgi

A pair of things to note - not sure if they matter but…
The executable uses caps AxcysConnex.exe
The CGI File is all lower case axcysconnex.cgi

The error log shows all lower case, which does match the file name of the cgi file but not the exe. In Windows normally case does not matter like linux.

Any other ideas?

Thanks all!

Got it solved.
This post had the answer
link text

If found it !
It was the first line in the .cgi file that needed to be adapted to Xamp’s configuration:


Instead of:



Sorry Tim, I assumed your CGI was a Xojo executable :slight_smile:
I’m glad you found the correct answer.

It remains a good thing you moved the root directory outside the “program file” folder.

About the high/low case, indeed it’s the same for Windows, so it’s unlikely to cause trouble when in a file path or name. Still it’s a good idea to take care of the case and be very cautious with that: you may have to deal with paths in your app, pattern match them, or do things that could themselves be case sensitive. And also, you could want or have to move your app to a linux server later.

No worries Renaud!
I appreciate your help and feedback. You set me on a better course!