Anyone missing the LINE decoration?

At a very few places I used to use the “Line Decoration” in the IDE. After having seen that it does not work properly (see this post) I fixed it with code.

Now I saw that the “Line” is gone. “Decorations” going down? In the existing distribution it was replaced with the “Oval” decoration. Still working but you can not edit it in the IDE properly. Try to draw a line from lower left to upper right corner - with the oval. :crazy_face:

I think this is not a good idea. You should be able to draw a simple line in every IDE used for graphical design. Not only vertical and horizontally - but also in any other angle. And if it’s not working its not a good idea to kill it instead of fixing it. Anyone else thinking like me out there? I can not find an open issue about that - is there any?

Thanks for your comments.

The Line control never worked well, for whatever reason. It’s always been better to just draw a line with a Canvas, or use a Separator control, depending on your needs.

1 Like

IIRC back when the ID was written in C (I know, ancient history), the line control worked reasonably well… Once they rewrote it in RB, it became an issue.

The problem with using Canvas is not being able to do WYSIWYG layout design as you can’t see the line

That said, the need for the line control is only when the line is not horizontal or vertical (Separator is fine for that) which while doing layout tends to be rare.

A line control that could have segments at different angles and optional arrows on the ends would however be welcome.


1 Like

See this. Top left closes, bottom right resizes.
Only one sample where I like to have it.

Can’t you draw it on the paint of the control under those green bits or do you need to tweak it visually in the IDE at design time?

Of course I could do everything in Xojo. This is not the issue. But if you are a “newbie” and simply want to draw an angled line it is not possible any more in the IDE. I drew this line in 2018 - and now it is an not editable oval control. I am just interested if more people miss it. It was simply silently killed. R.I.P. :headstone:

Any other IDE you can choose has a line item (and on top a separator probably).

I only used lines as separators (no click). In the end, I get / or \ instead of |.

So I draw a line in the Window background until I do stopped doing so (no more line).

What is your own use of a Line Control ?

Have-you looked at Object2D ?

This allows you to draw Object(s) in a Canvas…

I can’t imagine a worst PR issue to a RAD tool than being unable to create a control that “draws a simple line” correctly for YEARS. And the solution for not being able to make it, was removing it from the Controls Palette.