Any way to use 2017R2.1 ?

My last license is for 2017R2.1 and it worked perfectly to build for iOS before. Since then the system has changed.

I looked at the path to command line in XCode. By default it is set to point to
XCode 10.1(10B61)

I can also set it up to
XCode 9.2 (9c40b)

Whichever setting, the run button remains disabled.

Is there any way to get it to work under High Sierra ?

what version of Xcode do you actually have installed?

which does seem to be Xcode 10.1 (latest is 10.2.1)

You might be able to run apps in the iOS 9/10 simulator. But definitely not able to build for the App Store.

Maybe I can run an older version of the system in VMWare fusion…

but still not going to be able to submit them

Which is not to say there are still not use cases for older versions of XCode. I have a client with an Enterprise license where I still had to use a VM so I can compile to run under iOS 6.1 because they still use a number of old iPod Touch 4’s which can not upgrade past iOS 6.1

Pretty much all of my iOS apps never see the app store.