Any thing change with SMTPSecureSocket

Did anything change in 2018 R4 that could have broken my sending email routines using SMTPSecureSocket.

Suddenly they are not working?

Error? Platform? Code?

Mac, it’s been working for years.

No error at all.

Just to be thorough, you’ve implemented both the Error and ServerError event, correct?

Yes and just got an error 102.

I had similar problems with a different routine, I converted that to using MBS and that seemed to help. I guess I’ll do that here.

Try 2018 R3, if it works, just unninstall 2018 R4 as i did There are some posts about networking problems in 2018 R4.

No problem here with 2018r4 running Mojave. At least with addresses.

if SMTPSock.port = 587 then
SMTPsock.SMTPConnectionMode = 0
SMTPsock.SMTPConnectionMode = 1
end if
SMTPsock.ConnectionType = SSLSocket.SSLv23//or any other = true

Maybe server changed SSL versions supported?
Or password changed?

I had a similar problem recently with HTTPSecureSocket when using SSLSocket.TLSv1 (the default connection type). The web site would not respond until I changed it to TLSv1.2 or SSLv23. But TLSv1 was working with the same web site using Xojo versions prior to 2018R4. I think the web site server must have been updated recently and my customer just noticed the problem after upgrading my app. doh!

After seeing this I tried changing my SMTP connection type to SSLv23 thinking that would be best for compatibility for now but it did not work with my office 365 email account. Strange thing is that TLSv1.2 seemed to work ok and I thought that was the first thing SSLv23 tried… doesn’t it auto negotiate?

Many servers that use OpenSSL are configured to refuse all TLSv1 connections. Assuming a bug in 2018r4 is not to blame, this would be the prime suspect.