another weird mysql problem


I have a web app that connects to a mysql database. the host is ubuntu 32bit.
i created a user@% which i use in the web app to connect,

when i run on my laptop in debug everything works fine.

when i build and copy over to the linux box, the select queries work, but update queries fail. no errors, but no changes happen.
i’ve turned on the global log on mysql and i cannot see the update queries in it.

any ideas?

I really should have just just used the MBS stuff to begin with. every time i have an issue with Xojo database stuff, i try the MBS version and it just works.

still no idea whats up with the Xojo plugin, but hey-ho.

are the mysql server and your app running on the same box, when you copy it to linux? Or are you running your app on linux, but the mysql server is still on your laptop? It sounds like a GRANT problem. Check the mysql user, see if they have grants for update, delete, etc. If they are on different boxes, you’ll have to give them rights to cover that too.