Another stupid queston: libunwind and RPI


I have not tried it yet (In stupid meetings all day) but I cant
wait to try it!! Expect more stupid questions as I attempt
to make it work, but THANK YOU!!!



You don’t need to take anything into account with your controls with the exception of spacing.

Also, remember that you can load up a Linux VM on your Windows system and run the IDE there to see what the layout will look like since the Linux environment is very similar on a PC and a Pi. I like either Mint or CentOS depending on whether you’re a Debian or Redhat fan.


I could have been really obtuse and called it the Duke University ACC Bookstore release. That’s where Eric, Donnie, Marc, and Bob got their start.

Fingers crossed that IBM statements of the future of RHEL stay true, I sure like the CentOS releases

OK, I promised you stupid questions, and I will not disappoint you…

I downloaded and open the project:

I have Xojo 2019r1 – it asked if it could update
the project to that version. I said OK, and it did.
It did not ask me anything about Build Automation
or anything like that.

The code compiled and ran fine under windows.
I built it for 32bit arm, and copied the entire build
directory to the Pi, and ran it., it ran fine on the PI!
Thank you!!


I coped the GTK3 folder to my project, and also
grabbed the GTK3 “folder” looking thing from the
working xojo example project and dragged it into
my project. (I really don’t understand what that does
by the way) – I added the lines


to my application open event… erased the
build directory on the PC, then rebult the project
coped to the Pi, and NOPE – same bad looking
GUI with odd sized objects…

Any ideas on what I screwed up?

Look at the example’s App.Open event. That is the ONLY thing that you need to add to your App.Open. Remove the other calls.

Your Navigator for the modGTK stuff should look like this:

will try it in the morning – but I had the code


int the and that did not work
so I moved it to the I also set a break point
(on windows) and saw that the code was there.

One thing I see in your project, is that you have
modGTK3 (the globe looking icon in your tree above)
in my project (this is from memory, I am not near that
PC right now) I have a folder looking icon in my
tree, and it says GTK3 (I think) I will also verify this
in the AM



In your case, you should have both the folder AND the modGTK3 module in the Navigator list. However, the modGTK3.xojo_code module is all that you need since the folder contains a separate module used for debugging the CSS if you decide to start modifying it.

I would remove the Folder and then use the “File” -> “Import” menu option to import just the modGTK3 module file. Once that is imported, change the App.Open to call just the “modGTK3.InitGlobalGTK3Style()” method to handle the rest. That is all I do in my projects since I’m happy with the CSS values as they are.

Man, I am still not getting this to work…
See anything blatantly wrong here?
(pics of IDE below)

here is a directory listing:

07/18/2019 11:06 AM .
07/18/2019 11:06 AM …
07/18/2019 11:06 AM 3,781,236 test2
07/18/2019 11:06 AM test2 Libs
1 File(s) 3,781,236 bytes

Directory of M:\test2 libs

07/18/2019 11:06 AM .
07/18/2019 11:06 AM …
04/03/2019 09:32 PM 1,729,311
07/18/2019 11:06 AM 39,743
07/18/2019 11:06 AM 51,841
07/18/2019 11:06 AM 84,944
07/18/2019 11:06 AM 11,090
07/18/2019 11:06 AM 489,018
07/18/2019 11:06 AM 21,956
04/03/2019 09:32 PM 34,913,126
8 File(s) 37,341,029 bytes

 Total Files Listed:
           9 File(s)     41,122,265 bytes
           8 Dir(s)      21,032,960 bytes free

OK, it seems my stupidity is with out limit.
Here is what the screen looks like on RPI for
the modgtk3 test project… I ma not sure that
it is right after all…

So, after all the fuss, I don’t think I am getting the
“sample” project to work right.

Any ideas?

That looks correct. You’re never going to get a Linux/Pi project to look just like the Windows version (if that’s what you are aiming for).

Sorry to be such a spammer…
I got Tim’s example to work – sortof.
Does this look right? Here is a picture of Tim’s code
compiled and running on my Pi both with and
without the line

Still looks rough, is this the best I can expect?

Something is still very messed up – I cant get my code to look any different
even with ot without the code


It looks exactly the same on the pi with or without.

I am still missing something.
I have done the obvious, erased the build directories
and rebuilt etc…

That is what it should look like. And be aware that if the user uses a different window manager, it will look different yet again.

In Fact, here’s what the default modGTK test project looks like on Windows 10 with normal theming applied:

Just tried this and it works well on PI4 latest build… Previously i had issues with a backward looking Gui.

Does anyone know what its doing to make it all work?


This is as close as you’ll get unless you start modifying the specific GTK settings in the modGTK3 code itself.

This should go on the main web page under PI development, Its fantastic and very close. I only found it by searching the forum.

It’s available in the IDE now.