An INNO Setup question


Would someone know how to correct this. I did bring over a GZFile from the compiled files but it appears that it is not the correct file. I know little about INNO so if someone could help me as to what to do to correct this I would appreciate it. Thnk you.

The “MyApp Libs” folder that gets installed must be in the same state it was after Xojo built your app. The folder may either be named “MyApp Libs” or “Libs” but it MUST be next to your MyApp.exe. Be sure all the libraries inside that folder are the same after installing as they were after building.

Try launching Builds - MyApp/MyApp.exe after building to be sure everything built correctly before packing your installer.

Tim, thank you. I’ll give it a try. Appreciate it


I did as you suggested but though the setup file ran on my computer, trying to load on another worked but would not run. The .dll files are not being seen. I loaded folders then added the files as files and yet the .dll could not be seen. Maybe this is one for technical support.

When you’re loading the subfolders (Libs and Resources), the argument should be to load the folder contents recursively–you don’t have to list the files individually. I’m not presenting the code here --yet–but the wizard should be helpful with this.

In the .iss file check if the line where you add your program (Source:…) are the flags
createallsubdirs recursesubdirs

1 Like

Good morning, I used the wizard in all instances loading the two folders, then when it received the above message, I tried loading the folders then adding the files separately. The problem then became that the msvcr120.dll could not be found. This morning I intend to delete the INNO folder and try reloading to see if perhaps the program somehow didn’t load correctly. I did put in a message to Tech Support so perhaps they can help. I will check the .iss file.

Thank you for the time and ideas.

Sounds to me, like you need to include the Runtime DLL’s for this Windows Installation:

Maybe take a look here and here, for more information regarding Xojo App’s and the InnoSetup App and about the Runtime DLL’s “issue”.

I appreciate the reply, Sascha. I did turn on the "Include Runtime DLL’s as you suggested. Now the problem is with a file _GZipFile_init not being found. I’m not as knowledgeable when it comes to this short of reading and studying this issue I have to ask if anyone can point me in the right direction?

1 Like

This is the latest issue as I mention above. Would anyone know how to repair this? I have no experience with this so guidance would be appreciated. Thank you.

That dialog means your Libs folder is not the same way it was when the app was built. Could be the wrong location, could be missing a lib, could be anything. The flags createallsubdirs recursesubdirs are extremely useful for making sure you’ve got everything.

You could try posting your .iss configuration, but without having access to the build folder it could be a lot of guess work for the forum.

I can offer professional one-on-one support, but as a premium service not everyone is happy when I mention that.

1 Like

Tim, I appreciate the offer. My email address is <> if you could provide fees. Seems like I need to study this more as I have little understanding at the moment. I had used INNO in past, maybe ten years ago +/- and had counted on program to get the job done.

I think Tim put the link so you can contact him without posting your email on an open forum.

You may want to remove your email and visit the webpage to find Tim’s contact information.

I edited out the email address and I have contacted James to let him know.


One note:
I got GZip messages when customers installed on Windows 7, which is not supported.

This message says it can’t find a plugin method which is part of the plugin loading process. Did you get this message or something else? If you still have the message you saw handy, that would be useful information.

If it works before being packaged into an installer but doesn’t work after being installed by the installer, then something is probably different between the two folders. I do something like this in Inno Setup:

#define MyAppName "MyApplication"
#define MyAppVersion "1.0"
#define MyAppExeName "MyApplication.exe"
Source: "{#MyAppName}\{#MyAppExeName}"; DestDir: "{app}"; Flags: ignoreversion sign
Source: "{#MyAppName}\{#MyAppName} Libs\*"; DestDir: "{app}\{#MyAppName} Libs"; Flags: ignoreversion recursesubdirs
Source: "{#MyAppName}\{#MyAppName} Resources\*"; DestDir: "{app}\Resources"; Flags: ignoreversion recursesubdirs
1 Like