AllowDynamicHeight not working

I think this has been beat up a long, but it’s not working for me again.

I had thought that it wasn’t working because I was creating the CellData and caching it, and now I’m returning it on-the-fly from the RowData method.

I’ve tried setting the AllowDynamicHeight in a number of ways and places.
I’ve set the height of the only control in the custom cell to be minimum of 30.

When I show the row the text just flows off the bottom and overlaps the following cells.

I’m at a loss. Any help would be appreciated (I’ve lost a lot of time on this now)

You have set the height to be minimum 30, that’s good.
But did you also set the top to the top of the cell, and bottom to the bottom of the cell too?

yes I have.

Is there a trick to when you set the parameter to true?
I know I’ve seen this working.

I set the parameter to True directly in the IDE inspector.

1 Like

ok… that’s interesting. It’s not showing up in my IDE inspector ?$&$^!!!

So if you add a container control and change it’s super you never see this parameter in the IDE.
If you drag in a MobileTableCustomCell you do.

Yep, and when I do it that way the dynamic height works.
Is this a bug in Xojo, or was there something I should have been doing? I think this should have worked as I was doing it…

It’s not a bug. MobileTableCustomCells are not the same as a Container.

Am I misremembering or at one point wasn’t the prescribed way to create a custom cell by using a container control?

I guess I have a lot of cells built the wrong way. Is there a problem with leaving them as container controls with the super set to MobileTableCustomCell? And I guess once I set the Super to that, I would have expected it to pickup the behaviors of its superclass.

Forum for Xojo Programming Language and IDE. Copyright © 2021 Xojo, Inc.