Adding aab in Playstore

Hi All

Followed the instructions…

Publishing your app to the Google Play Store — Xojo documentation

… to add an app to playstore I have generated the jks and a text file using the format shown in above doc.

There are no spaces commas or special characters used in the generation of the jks or properties file.

After creating the aab file and trying to upload it to google in the create initial testing release i get the message

The Android App Bundle was not signed.

Any thoughts please!

I followed the Xojo YouTube Android Signing

Might help you

Xojo should create the signed abb file by itself. What is the point of having “Xojo android” if you have to install and do various process in Android studio anyway… :roll_eyes:

OK solved the issue as follows

the private_key.pepk path was set to desktop so I changed it to the same folder as the jks

I then got an error saying android studio/xojo could not find the jarsigner.exe when building the file . It seems that xojo is looking for jarsigner in android studio/jre/bin but its in android studio/jbr/bin

eventually I copied all contents of the jbr to jre and all works as it should.

Not sure if its my system settings are wrong or xojo looking in wrong place. I guess the may be a better way getting things in the right place this one worked for me.