about naming variables and classes...

I have an enumeration in my class called LEVEL.
I also have a variable in my class called Level of type LEVEL.
Am I going to confuse the system by having a name like level and a enumeration like LEVEL?
Observing the screen shot below… Where is the enumeration LEVEL? Notice that ROOT and Root exist?

[quote=32791:@Brian O’Brien]I have an enumeration in my class called LEVEL.
I also have a variable in my class called Level of type LEVEL.[/quote]
This is a horrible idea - dont do it

This can have weird effects depending on the specific syntax of a particular line of code that uses either of these. I’d call the enum something else like “LEVELS”.

I’d be more concerned about confusing myself. Consider prefixing. Like this: enumLevel

Not a good idea.

Use Joseph’s example and prefix all enumerations with something like ‘enum’. If you have any structures prefix them with something like ‘struct’.

That way you will not confuse yourself or your application.