A development profile is required when building an iOS application. Yet Again.

I’ve got an iOS app that runs great in the Simulator. So today I ponied up for an Apple Developer account and a shiny new Xojo iOS license. I’ve religiously followed the steps in “Ad-Hoc iOS Device Deployment for Testing” but when I build my app it fails with the dreaded “A development profile is required when building an iOS application.” message and the app doesn’t get created.

I’ve got a single iOS Development Certificate, which I’ve downloaded and installed in KeyChain Access by clicking on it.

I’ve got a single App ID, bog standard with no application services. The prefix matches the Team ID in my account.

I’ve got a single iOS Development provisioning profile created by Xcode:

Weirdly, I’ve got 2 settings in Xcode>Preferences>Accounts.

Under the Agent setting everything looks copacetic.

Over in the Xojo Build Settings, I’ve selected the only team option available to me.

I’ve already deleted everything from previous tries, including all certs from Keychain Access and now I’ve just got the one cert there plus one of everything else as shown above. Can anyone suggest something else to try?

I just install the Apple Worldwide Developer Relations Certificate Authority cert in Keychain Access and noticed this:

Could that invalid issuer warning be the problem?

See https://forum.xojo.com/30206-certificate-confusion/0#p247955

Thanks, Michel. I’ve fixed the expired auth cert problem by downloading the new one. Deleted all my certs and started over from scratch again with a new iOS Development cert which I verified was installed in Keychain and is valid. Let Xcode create a new provisioning profile. No joy. Created a manual provisioning profile and am still not able to build the app. Same message as the title of this thread.

In the screenshot, the IOS developer profile is the only one with ‘Reset’ next to it
Is that significant?
What happens if you select ‘reset’?

I also still have this issue, even after I fixed my certificates (at least I can codesign my apps again now). Strangely enough the build will fail only when I select a signing identity in the build settings of the IDE (Team), not if I leave it on “none”.

[quote=248071:@Jeff Tullin]In the screenshot, the IOS developer profile is the only one with ‘Reset’ next to it
Is that significant?
What happens if you select ‘reset’?[/quote]
Nothing that I could tell. Since I redid everything, this spot is blank as it should be after selecting Create.

If I set the team to “None” I don’t get the error message like I do if I set the team, but either way when I attempt to install the app on the device it gets rejected with “No Code Signature Found”.

Should the Sign step of Build Settings look like this?

Turns out it was the iOS Team Provisioning Profile created by Xcode. I created a manual provisioning profile that did the trick.

Another tip: When you’re deleting old certificates from Keychain Access, look under Keys and delete the old public and private keys as well.

Have been trying to load my app to an iPad for several days.
Well today I finally got it to work. And I don’t know why this time.
What I did was to create a new ID, with full bundle as the ID, not the * wildcard.
Then created a new Profile and downloaded, install the Profile on the iPad, by double click the download file. Then built the app, getting a message about “codesign wants to sign using key” and so forth. After completing the compile uploaded app to iPad and it worked.

Been fighting this thing for over a week. What a relief.


Yes ot still going. I have been working it for three days now and watched dozens of youtube videos, read dozen of articles. Deleted every so many times, it is just insane. And most of the stuff I have found is over a year old. Some the refferenced articles in these forums have been deleted or are invalid.

lol, is there a teamviewer service to truly help with?

James Wadkins