100% CPU for Web on Server 2012

Hi, I just bought a xojo pro license! There seems to be some cool people here :slight_smile:

Here’s the behavior:

I’m using Amazon EC2 to host my xojo web app as Stand Alone.

The after loading the .exe it sits at 0% CPU usage. When I make the 1st request it will use up all remaining CPU peaking it to %100.

I thought it might be my app so I loaded the “Login Example” from the example code as I used that example as a base for my project.

To my surprise the same thing happened! I let it sit there for an hour. As long as the browser stays open on a remote device, it’s peaking the cpu of the server.

Now I’m curious… Is the CPU really weak? Is this related to Windows Server 2012 x64?.

So I start up a fresh instance of server 2008 r2.

The exe takes up exactly %60 CPU without touching anything. I let it sit there doing nothing for 10 minutes. OK I load the landing page. It peaks to %99 for a second and now behaves perfectly.

This is replicable with the “LoginExample” build as a standalone exe

Thanks for any input you can provide. Server 2008 r2 x64 seems fine while 2012 is unacceptable.


maybe you have an endless loop there?

I’m using the LoginExample just to make sure it’s not my code. There are no loops in the example.

It effects the sample code as well. I’ve started a totally fresh copy of server 2012 again just to be sure. %100 CPU for a stand alone web exe using the “LoginExample” Bundled with xojo. Used port 9000 just to be sure of no conflict. Any ideas?

Just a shot in the dark here…What happens with an empty project? That is, create a new project and build it directly.

Could be related to <https://xojo.com/issue/30328> ?

I have had this problem. On my 5 year old laptop (which I use for developing) the compiled app worked fine as a standalone. The performance was “instant”. Yet I could not get the app to run on aws reliably, the cpu always maxed at 100%.

I had a “windows micro instance” for apache and was using an “rds micro mysql instance” for data. In the end I tried lots of different types of instances (micro, small, medium, 32bit, 64bit etc.) to find why the cpu was maxing out. I found that by ditching the rds and running mysql locally instead, that I removed a bottleneck at the data level. The rds was in part causing a delay because of its poor performance. While the program was waiting for rds to slowly reply, it consumes cpu.

I also changed my vps instance to be a “t2.Medium” as it more closely matched the specs of my laptop, I now think the micro and small instances are completely unsuitable (not enough grunt). Eventually I also learned (by trial and error) that not all vps instances are created equal. Now I end up spinning up a few instances, until I get a good one. Sometimes they are really bad, sometimes really good. Must be lots of noisy neighbours around!