Slow, and not functional

  1. 8 weeks ago

    Victor M

    Feb 11 Pre-Release Testers

    My MacBook with 16 Gb of Ram
    3.1 GHz Intel Core i7

    I just want to comment that Xojo is slower and harder to work every day, MBS add-ons become heavy and opening and compiling a project every day is more difficult.

    Before working at Apple was really efficient, now it seems that I am on Windows

  2. Mike C

    Feb 11 Pre-Release Testers, Xojo Pro North Carolina (USA)

    @Victor Mnbsp;Osornio My MacBook with 16 Gb of Ram
    3.1 GHz Intel Core i7

    I just want to comment that Xojo is slower and harder to work every day, MBS add-ons become heavy and opening and compiling a project every day is more difficult.

    Before working at Apple was really efficient, now it seems that I am on Windows

    What version of Xojo are you using? I have 2019 r1.1 open for hours each day with similar MacBook Pro specs and I do Not have this issue. I load all of MBS’s plugins additionally. I do notice some lag in the IDE over time but a restart of the IDE solves that that for me.

  3. Dave S

    Feb 11 San Diego, California USA

    I too have a simlar setup... 2019r1.1, and have no issues.... only difference.... I do not have MBS

    and only restart the IDE when I'm starting a new day of programming... never have to restart due to "issues"

  4. 7 weeks ago

    Jeff T

    Feb 11 Pre-Release Testers Midlands of England, Europe

    Are you using 'OneDrive'?

  5. Beatrix W

    Feb 11 Pre-Release Testers, Third Party Store Europe (Germany)

    Why should the compile speed vary? There have been reports about problems with the IDE. But the compile speed is always the same. Yes, the MBS plugins make starting the IDE rather slow. But it's rather simple to only load the needed plugins.

  6. Michael H

    Feb 12 Pre-Release Testers, Xojo Pro Europe (Hamburg, Germany)

    On my Macs the last couple of versions of Xojo have always been responsive; I have experienced no slow-down. I rarely restart the IDE; it’s open all the time. I’m not using MBS plug-ins though.

  7. Mark C

    Feb 12 Pre-Release Testers, Xojo Pro Spain 03170

    for me 19.3 has been also very slow, I am now back to 19.1 and no issues at all, no MBS or any other plugin.

    iMac Late 2012 i7 BTO 32G ram, 3Tb fusion drive, 10.13.6.

  8. Julian S

    Feb 12 Pre-Release Testers, Xojo Pro UK
    Edited 7 weeks ago

    Out of interest if you're suffering from a slow ide could you install/move that edition of xojo to a ram disk and let us know if there is any change? Could you try the different formats too?

  9. Mark C

    Feb 12 Pre-Release Testers, Xojo Pro Spain 03170

    Julian, if that was aimed at me then yes, with the instructions how to do that.

  10. Anthony C

    Feb 12 Pre-Release Testers, Xojo Pro, XDC Speakers, Third Party Store, Forum Moderators, MVP GraffitiSuite Developer
    Edited 7 weeks ago

    Please also add any relevant information to the Feedback Case for this: Feedback Case #56900. It's important that this information get logged there so that Xojo engineers can directly access it in that environment.

  11. Julian S

    Feb 12 Pre-Release Testers, Xojo Pro UK
    Edited 7 weeks ago

    @Mark C Julian, if that was aimed at me then yes, with the instructions how to do that.

    It was targeted at everyone/anyone that is experiencing the slow down but here's how.

    Make sure Xojo is not running.

    Open a terminal window and cd to your Desktop

    Copy the following command to your terminal window, this will create an approximately 6GB ramdisk formatted as HFS+

    diskutil erasevolume HFS+ 'RAM Disk' `hdiutil attach -nomount ram://12582912`

    Drag your entire Xojo 2019 Release 3.1 folder from your Applications folder to the RamDisk with the Command key held down to ensure its moved and not copied, you might need to enter your password to perform this action.

    Give xojo a few starts by double clicking it directly from the ramdisk to make sure that everything is settled down then try your usual routine that shows a slowdown and see how you get on.

    When you are done, you can move it back into the Applications using the same drag with Command key held down and confirm the move with your password. You might get an error saying the copy took place but not all files could not be deleted, check the ramdisk and see if the Xojo folder is empty then you can delete it manually.

    To remove the empty RamDisk, right click it on the desktop and click Eject.

    Could you then repeat all tests on an APFS ramdisk with the following command:

    diskutil erasevolume APFS 'RAM Disk' `hdiutil attach -nomount ram://12582912`

    Note: When you mount the drive, it if doesn't show on the desktop and open its drive window check its there in Disk Utility, click it, then click Mount.

  12. Norman P

    Feb 12 Pre-Release Testers, Xojo Pro outside enjoying the fresh air

    this will only help if the IDE is I/O bound
    if its something else, like CPU bound etc, this probably wont make much difference

    but that information alone may be useful to Xojo

  13. Mark C

    Feb 12 Pre-Release Testers, Xojo Pro Spain 03170

    ok thanks, this will be tested some time soon.

  14. Norman P

    Feb 12 Pre-Release Testers, Xojo Pro outside enjoying the fresh air

    I recalled that Tim jones had already done something like this on Linux as it was particularly slow there
    https://forum.xojo.com/conversation/post/430635

  15. Paul R

    Feb 12 Pre-Release Testers, Xojo Pro Kirkland, WA

    On MacOS Catastrophe (10.15), launching the IDE with more than a couple of plugins is lunch-break-inducing, since each plugin seemingly has to be checked with the Apple mothership to make sure it isn't a bad player. I wish I could use MacOS 10.14, but 16" MBP...

  16. Bill M

    Feb 12 Sedona, AZ

    On my mac pro Xojo 3.1 with all MBS plugins take 9 seconds to open.

  17. Scott C

    Feb 12 Pre-Release Testers, Xojo Pro twitter.com/ScottCadillac

    With my Mac Mini (2018), 3.2 GHz 6-Core Intel Core i7, 32Gb RAM, running Catalina 10.15.3 with Xojo 2019r3.1 and about 25 Plugins, my Xojo startup time is 24 seconds.

    That's with an unzipped plugin install, as discussed here https://forum.xojo.com/57793-unzipped-plugins-still-possible/

    Overall I get good IDE and compiling performance with Xojo.

  18. Mark C

    Feb 12 Pre-Release Testers, Xojo Pro Spain 03170

    Bill/Scott

    the slowdown in my notation is not the startup time, its every time I run to debug, it is painfully s-l-o-w with >19r11 to the point I do not want to use it.

    initial boot time is not for me of any issue as its only once in a while, I have always left the working project open for months without ever restarting the IDE and that had never raised a single problem.

    this slow debug launch has never been an issue for me previously, even though others have had the same slow down issues in earlier versions.

    clearing the cache has no effect, it just sits spinning the beachball for varying amounts of time when debugging, I am not interested too much in testing why, it is simply not able to give me any joy to code with.

    19r1.1 works perfectly acceptably, and for the moment that is the fix I am sticking with, joy has returned to my coding life!

  19. Anthony C

    Feb 12 Pre-Release Testers, Xojo Pro, XDC Speakers, Third Party Store, Forum Moderators, MVP GraffitiSuite Developer
    Edited 7 weeks ago

    @Mark C the slowdown in my notation is not the startup time, its every time I run to debug

    Make sure you have Optimization Level set to Default in the Shared Build Settings,

  20. Tim J

    Feb 12 Pre-Release Testers, Xojo Pro N. Phoenix, AZ

    @Mark C 19r1.1 works perfectly acceptably, and for the moment that is the fix I am sticking with, joy has returned to my coding life!

    You've joined a rather sizable cadre of misfits in sticking with 19r1.1. I wish that Xojo had the staff to make it a long term support (LTS) version that would stay feature-static, but receive fixes.

  21. Newer ›

or Sign Up to reply!