Xojo 2019r2 silently dies on start

  1. 7 months ago

    Björn E

    2 Nov 2019 Testers, Xojo Pro Iceland

    My Xojo 2019r2 on Mac started just now to silently die on start every time.

    It posts License agreement (don't even know why its posting that since its not first time I use it) then I press Agree, and then Xojo is dead.

    Does anyone have any idea ?

  2. Rick A

    2 Nov 2019 Testers, Xojo Pro (Brazil. UTC-3:00)

    Try re-downloading a new copy

  3. Björn E

    2 Nov 2019 Testers, Xojo Pro Iceland

    Am downloading a beta now I guess. To see how that goes. Its basically as if it treats the Agree Button as Disagree and exits out. Will report back in a bit when I have the download.

  4. Björn E

    2 Nov 2019 Testers, Xojo Pro Iceland

    No same issue, fresh download press Agree and its dead.

  5. Rick A

    2 Nov 2019 Testers, Xojo Pro (Brazil. UTC-3:00)

    You may try to run Xojo from the terminal and see if it reports something there.

  6. Björn E

    2 Nov 2019 Testers, Xojo Pro Iceland

    Just did that, noting at all comes in the Terminal. Its like it blatantly treats the agree button as disagree and quits.

  7. Norman P

    2 Nov 2019 Testers, Xojo Pro outside LMAO !!!!!!!
    Edited 7 months ago

    old mbs plugin installed ?
    there was some note about the IDE loading plugins that would cause the IDE to die

    do you even see it try to load the plugins ?

  8. Björn E

    2 Nov 2019 Testers, Xojo Pro Iceland

    No plugins at all installed just the ones that come with Xojo.

    Mysteriously then older Xojo's are also suddenly popping up license window. But they don't blatantly shut down when I press Agree though.

    Am working on creating new user on the machine to test that but its taking some time since it wants finger prints and god knows what.

  9. Björn E

    2 Nov 2019 Testers, Xojo Pro Iceland

    ok so it does start on new user.

    That moves the questions to....does anyone have any idea what I need to clean to get the main user fixed ?

    Thanks

  10. Norman P

    2 Nov 2019 Testers, Xojo Pro outside LMAO !!!!!!!

    move the preferences out of ~/Library/Preferences
    dont delete it though
    see if a new prefs file fixes it

  11. Beatrix W

    2 Nov 2019 Testers, Third Party Store Europe (Germany)

    Wasn't there something with a date format what could kill Xojo? Something like Xojo didn't like the 12 hour date format?

  12. Björn E

    2 Nov 2019 Testers, Xojo Pro Iceland

    Yes spot on Beatrix I was doing tests with TimeControl 2 nights ago, and had changed the clock from 24 hour to 12 hour format.

    Changing it back fixes it.

    Thanks...

    This really really needs fix I would say since users hitting this are not likely to have a fix easily !

  13. Björn E

    2 Nov 2019 Testers, Xojo Pro Iceland

    Seems bug:

    56853 - Betas not running if Mac system clock is not in 12 hour time format in UK

    Which is marked as fixed is not fixed at all.

  14. Norman P

    2 Nov 2019 Testers, Xojo Pro outside LMAO !!!!!!!

    yeah its not
    I just tried it again in the latest beta and it still doesnt work
    Feedback Case #56853

  15. Gavin S

    2 Nov 2019 Testers, Xojo Pro, Forum Moderators, MVP UK

    Yep, reported this many times during the betas. Didn’t seem to be taken seriously. Couldn’t be bothered trying to report it yet again so just changed my system clock. But I wonder how many people try Xojo out for the first time and give up when it silently quits.

  16. Greg O

    2 Nov 2019 Xojo Inc scout.galaxy.barn

    @Gavin S Yep, reported this many times during the betas. Didn’t seem to be taken seriously. Couldn’t be bothered trying to report it yet again so just changed my system clock. But I wonder how many people try Xojo out for the first time and give up when it silently quits.

    Actually... we did look into it and fixed the issue we saw. Obviously there’s another dimension we didn’t see, but since you ”Couldn’t be bothered trying to report it yet again so just changed my system clock” we weren’t aware of this.

    Bjorn, please create a new case with as much info as you can give us. Screenshots of your language and locale system preference windows would be very helpful.

  17. Norman P

    2 Nov 2019 Testers, Xojo Pro outside LMAO !!!!!!!
    Edited 7 months ago

    @Gavin S Yep, reported this many times during the betas. Didn’t seem to be taken seriously. Couldn’t be bothered trying to report it yet again so just changed my system clock. But I wonder how many people try Xojo out for the first time and give up when it silently quits.

    I just asked my case be reopened since I just tried the exact same steps and it still halts 2.1 from starting
    Simply setting my preferences to Region > UK
    Time format 12 hour (24 hour disabled) and 2.1 wont start
    Switch to 24 hour it works

    Switch region to Canada and it works in either setting for the time

    I've posted a movie of this

    Its the exact issue I reported with the same steps I reported and its definitely not fixed

  18. Björn E

    2 Nov 2019 Testers, Xojo Pro Iceland
    Edited 7 months ago

    Yes is pretty much waste of time for me to report new case when it can be reproduced the same way as before. Xojo just needs to re-open the case.

  19. Edited 7 months ago

    Thank you Bjorn/Beatrix, if you had not raised this/suggested solution I would still be assuming that my laptop running El Capitan 10.11.6 was simply too out of date. (And cursing the powers that be for not updating the "requirements" page.)

    I had exactly the same issue, Xojo 2019r2 launching, verifying, then showing license agreement, then quitting/crashing when clicking "agree".

    Had region set to "UK", time format on 12 hour (i.e.: 24 hour check box unchecked) ...

    Clicked "24-Hour Time" check box in "Language & Region" system pref pane, now it's fine.

    Only because I happened to notice Bjorn's posting, and Beatrix's solution. As somebody else mentions above, I wonder how many are trying the new version and just giving up. Not good.

  20. Alberto D

    2 Nov 2019 Testers, Xojo Pro Austin, Texas
    Edited 7 months ago

    Did a test with Xojo 2019r2 and 2018r3:

    • Start with USA Region
    • Open 2018r3 no problem
    • Open 2019r2 no problem
    • Change the region to the UK and untick 24-hour clock
    • Open 2018r3 no problem
    • Open 2019r2 the License Agreement show and after Agree, Xojo closes
    • Open 2018r3 again and instead of opening Xojo the same as before trying 2019r2 the License Agreement show too, but at least 2018r3 can continue at this point

    Edit: added a case with a simple video to reproduce the problem with Xojo 2019r2 Feedback Case #58122

  21. Newer ›

or Sign Up to reply!