Anybody using SQLite?

  1. 2 weeks ago

    Tomas J

    May 13 Pre-Release Testers, Xojo Pro Europe (Germany)
    Edited 2 weeks ago

    Interesting CVE-2019-5018 with high CVSSv3 Score 8.3. Proof of Concept shown here:
    https://www.talosintelligence.com/vulnerability_reports/TALOS-2019-0777

  2. Christian S

    May 13 Pre-Release Testers, Xojo Pro, XDC Speakers Germany

    Interesting. But patched already as far air says...

  3. Tomas J

    May 13 Pre-Release Testers, Xojo Pro Europe (Germany)

    Not in Xojo:
    http://docs.xojo.com/Resources:2019r1_Release_Notes

  4. Greg O

    May 13 Xojo Inc

    Considering that cve came out last week and 2019r1 has been out a month, I’m not sure what you’re asking.

    We have a policy now that a SQLite release must be stable for 6 weeks before it can appear in Xojo because we’ve been bitten by quick release bugs too.

  5. Tomas J

    May 13 Pre-Release Testers, Xojo Pro Europe (Germany)

    No blame intended, was just an answer to Christian. The SQLite bug is very interesting and bites my apps aswell.

  6. Christian S

    May 13 Pre-Release Testers, Xojo Pro, XDC Speakers Germany

    If needed I can of course offer a rebuilt MBS Xojo SQL Plugin with the fixed SQLite.

  7. Jean-Yves P

    May 13 Pre-Release Testers, Xojo Pro Europe (France, Besançon)

    @Greg OLone Considering that cve came out last week and 2019r1 has been out a month, I’m not sure what you’re asking.

    We have a policy now that a SQLite release must be stable for 6 weeks before it can appear in Xojo because we’ve been bitten by quick release bugs too.

    isn't it possible to make sqlite an external plugin like other databases, so that each one can use the version he wants, and eventually return to an older version if the current has a bug that prevents him to build his apps ?

  8. Greg O

    May 13 Xojo Inc

    @Jean-YvesPochez isn't it possible to make sqlite an external plugin like other databases, so that each one can use the version he wants, and eventually return to an older version if the current has a bug that prevents him to build his apps ?

    Not always. There are times when plugins are tied to particular ide versions because of other prerequisites.

or Sign Up to reply!