Orange Pi Lite - WiFi HELP

  1. last year

    Mark S

    20 Aug 2016 Pre-Release Testers, Xojo Pro

    Well after some issues with shipping I have received my Orange Pi Lite.

    I created an Armbian image on an SD card and it booted up. I have a GUI desktop but I cannot get the WiFi to connect. The built in Wicd Network Manager can see my SSID and it says it has my WPA 2 encryption. I enter my key and click connect. It attempts to authenticate but finally gives up with "Bad Password". I have two SSID's on my router. My main network and a Guest network. Neither will connect.

    Björn Eiríksson said he had tested the Lite model. Björn if you are watching how did you get WiFi to connect?

    Thanks

  2. Björn E

    20 Aug 2016 Pre-Release Testers, Xojo Pro Iceland

    I don't put them on Wifi usually. Though I did have Orange PI Plus 2 on Wifi for a while. I don't remember having had any issues connecting. I can do tests tomorrow I have some Orange PI's with me where I am now.

    You might want to check the Armbian forum. There are lots of people there that will have the answer.

  3. Björn E

    20 Aug 2016 Pre-Release Testers, Xojo Pro Iceland

    Check this thread here:

    http://forum.armbian.com/index.php/topic/1713-solved-opi-lite-wifi-cannot-connect-to-wpa/?hl=%2Borange+%2Blite

  4. Mark S

    20 Aug 2016 Pre-Release Testers, Xojo Pro

    Björn,

    The reason I got the Lite was the built in WiFi.

    The link you posted above looks hopeful. I did some Googling but I did not see any Arabian.com answers. I will remember to check that forum first.

    Thanks for the help.

    Mark

  5. Mark S

    22 Aug 2016 Pre-Release Testers, Xojo Pro

    Björn,

    I was able to change the Wicd settings using the information in the link above and it is now connected to my WiFi. THANK YOU.

    BEWARE - Here is some help others might find useful.

    It was a bit confusing. When I first opened the Wicd Network Manager dialog I could NOT find any security settings. I decided to make the dialog wider by dragging with the mouse and I found more options on the tool bar. It had no indication, other than a little triangle pointing down, that there were more options until I changed the size of the dialog. I suppose this falls under the category of "operator error" although maybe it is "operator inexperience with this desktop manager. ;-))

    As referenced by one of the posts in your link above I set the Driver under WPA Supplicant to the "second" NONE and it immediately connected when I closed the dialog and clicked Connect. I did not try any of the other settings so some may have worked.

    I have two SSID's and one has a WPA passphrase that looks like a hex string. There were some references in the various posts in the link above that made it appear that there was a problem with text versus hex passphrase but I did not find that true.

    Thanks for the help.

    Now on to doing something useful with the board.

    Mark

or Sign Up to reply!