Apple push notifications in Xojo iOS app

  1. ‹ Older
  2. 5 years ago

    How you set up remote notifications? Or local notifications? I already posted classes for local notifications, although come to think of it I don't think they are in iOSKit right now.

  3. Greg O

    9 Sep 2015 Xojo Inc scout.galaxy.barn

    We did remote notifications to Passbook, not to an individual app.

  4. Martin K

    2 Nov 2015 Testers, Xojo Pro Stockholm, Sweden

    Any updates on RemoteNotification?

  5. Martin K

    6 Nov 2015 Testers, Xojo Pro Stockholm, Sweden

    @Greg OLone We did remote notifications to Passbook, not to an individual app.

    any chance xojo can help jason here?

  6. The issue is not that I can't figure it out, but that I haven't had the time to finish putting it together yet. I should be able to finish this at the of the month, but until then you will have to wait unfortunately.

  7. Martin K

    6 Nov 2015 Testers, Xojo Pro Stockholm, Sweden

    I know Jason, i just have the feeling that there is a lot of xojo users wanting this and it might be unnecessary stressful?

  8. Jaap C

    10 Nov 2015 Testers, Xojo Pro Europe, Holland

    Maybe the MBS plugin of Christian Schmitz has already something for it?
    Made it also for OS X years ago!
    I need this also early next year...

  9. Martin K

    10 Nov 2015 Testers, Xojo Pro Stockholm, Sweden

    well we can't use plugins for iOS.

  10. last year

    Valdemar D

    23 May 2019 Testers, Xojo Pro Europe ( France, Paris )

    Has someone update the Jason project with last API ?

  11. 2 weeks ago

    Boudewijn K

    Jun 19 Testers, Xojo Pro Amsterdam NL, Fischer Tx

    @Jason K : the project you shared does not compile in the current Xojo compiler; any chance of an update?
    Or did anyone else manage to update it? There are several "Type Mismatch error. Expected UInt32, but got Ptr" Errors.

  12. Where are you seeing these errors, and can you give more details on what files are causing them? you might need to update the modules folder with the latest version of iOSKit from github

  13. Boudewijn K

    Jun 20 Testers, Xojo Pro Amsterdam NL, Fischer Tx

    @Jason K : Here's the screenshot with errors when compiled with Xojo 2019R3.1 on Catalina;

    -image-

  14. Jeremie L

    Jun 20 Testers, Xojo Pro, XDC Speakers, MVP Europe (France) - packr.app

    @Jason K you might need to update the modules folder with the latest version of iOSKit from github

    That's is the solution Boudewijn.

    https://github.com/kingj5/iOSKit

  15. Boudewijn K

    Jun 20 Testers, Xojo Pro Amsterdam NL, Fischer Tx

    @Jeremie L : Thanks Jeremie. If you don't mind me asking; which items do I need to copy over?

  16. Boudewijn K

    Jun 20 Testers, Xojo Pro Amsterdam NL, Fischer Tx

    @Jason King: Any chance of getting the improved iosapplication updated?

  17. Jeremie L

    Jun 20 Testers, Xojo Pro, XDC Speakers, MVP Europe (France) - packr.app

    Delete the Foundation module from "improved iosapplication".

    Copy "iOSKit" folder from iOSKit project to "improved iosapplication" project.

  18. Boudewijn K

    Jun 22 Testers, Xojo Pro Amsterdam NL, Fischer Tx

    Forgive my ignorance, but my iOSKIT does not have a IOSkit folder, only an IOSKit Master, and within there, the Modules folder. When I add those, I end up with 794 errors, which is why I asked if it might be possible to get an update from @Jason K

  19. Derk J

    Jun 22 Testers, Xojo Pro

    @BoudewijnKrijger Forgive my ignorance, but my iOSKIT does not have a IOSkit folder, only an IOSKit Master, and within there, the Modules folder. When I add those, I end up with 794 errors, which is why I asked if it might be possible to get an update from @Jason K

    Open the project then youll see the folder in the ide

  20. I can update the project this weekend if needed, but please do as Jeremie said above:

    1. Download iOSKit and open it
    2. Copy the Modules folder from iOSKit
    3. Delete the "Foundation" module from the improvedIOSApplication example project
    4. Paste the modules folder
    5. Click run - it will now work :)
  21. 5 days ago

    Boudewijn K

    Jun 29 Testers, Xojo Pro Amsterdam NL, Fischer Tx

    @Jason K : The app now runs, but I get an error "no valid "aps-environment" entitlement string found for application.

    I do have an info.plist with the key:

    aps-environment : development (also tried production, but the same result)

    but when I push the Register for remote Notifications button, I still only get this error.
    I would greatly appreciate your assistance.

or Sign Up to reply!