MailSocket not working in 2015r3?

It appears to be a normal socket

Thank you Travis. I saw it was moved to verified in the feedback case. I’ll try to come up with a solution for my users in the meantime until the fix is ready

I am successfully sending email via SendGrid using these settings.

MailSocket.Secure = True MailSocket.ConnectionType = SMTPSecureSocket.TLSv1 MailSocket.SMTPConnectionMode = SMTPSecureSocket.ModeSSLTLS MailSocket.Address = "" MailSocket.Username = App.SendGridUserName MailSocket.Password = App.SendGridPassword MailSocket.Port = 465

Where MailSocket is a subclassed SMTPSecureSocket.


Genius Wayne! Just tried a test email message, and it went through! I’m wondering if when I added the secure socket setting I had the port as 587. Using the code above worked! Thanks for your help!

@Ryan Hartz glad to be of help. Don’t forget to update that feedback case.

That was my first feedback submission, so not sure how I can add to it/edit it. Looks like the Xojo team made a fix and are waiting for testers to check out the fix

I guess Xojo have the issue in hand then. To add notes to a case look at the bottom left corner of the case for the pencil icon.

Thanks Wayne. I added some comments to the feedback case with your post