Image Problems in Windows on Projects Compiled under Mavericks

[quote=61622:@Joe Ranieri]The cause of the black images bug is still unknown, but I believe that switching to PNGs will eliminate the problem. As for the Haswell issue, it’s a known issue in Mavericks and a fix will be rolled out in some future software update.

So, it’s “fixed” in that Xojo users won’t have this problem anymore.[/quote]

So then PNGs don’t have the black issue or the Haswell issue? We are positive on that?

The Haswell issue is definitely not applicable of PNGs (and it has been tested). As for the black image issue, nobody from the alpha program has seen the issue yet.

[quote=61608:@Joe Ranieri]It’s fixed in the next release, which is currently in alpha stage.


An estimated time ? We need this fixed …


[quote=61651:@Raimon Fernandez Sirera]An estimated time ? We need this fixed …

2014r1 - in Q1 2014

Just wanted to add my observation:

This seems to have suddenly begun affecting me only after I used Quartz Debugger to enable Retina Display on my non-retina Macbook Pro.

I turned on Image Tinting to tint low res images, and even though I have turned that option off now the OS is still coloring things pink sometimes. If I try to double the size of an image in Pixelmator, the OS changes the image’s color profile to a strange green tint.

I don’t know exactly how that would affect Xojo builds, but since it’s affecting Pixelmator I think it’s a good possibility that it’s affecting graphics in other apps. If I had a good way to reverse what Quartz Debug does it would make it easier for me to verify if it’s related.


I was able to revert the Quartz Debug settings by turning off image tinting, disabling Quartz Debug, logging out and logging back in again.

Now the problem is resolved: before I had black squares, now there are images again.

Maybe this will help someone else?

Detective fail: I now suspect that the restart is what cleared it up, not disabling Quartz Debug / Retina mode.


The black squares are usually fixed by restarting Xojo.