How do you keep track of all information!? -- Solved!

Jakob, with OOP directed to help you to keep track of what object you are using, why external calls that deny any OOP principle?
You could always address WindowA1.UpdateUserInterface and so on. And yes, that’s what classes are meant for.

Kem, Tim and others. With the greatest respect, I think we speak about different things.

It’s more an issue of naming, rather than the use of Classes or OOP or Methods. No matter the technique, the naming issue and the confusion remains.

I sometimes leave the project for a few weeks or some months. Then, when I come back, it really takes forever to get into the pace. The image will solve that.

Say, I want to add another component in the Settings. Then, I know the Window and I can easily find the code connected to that Window. To add interaction and change the INSERT command.

But then, maybe the Tabs should be zero-based…! :slight_smile:
In such sense, the confusion will remain for the people looking in the complied code while a person looking in Xojo will be fine.


I don’t have the knowledge, the resources and the financially possibilities to do things by the book. So, it’s a poor man’s solution to an expensive experiment. For me, the result is all that matters. It’s a challenge to get there but eventually, it seems to work!

With such ABC naming, there will be no need for pen and paper. I still think things may be confusing for me, but at least very many issues will be solved only by a fast glimpse. Little confusion is fine.

Thank you all for inspiration! :slight_smile:


EDIT: B3updateSettings would be an even better name on that Method…! :slight_smile:

What works for you works for you.

I do not think working by the book requires “financial possibilities”, though.

I’ve now changed ALL names in the software, App1, as I just came up with! :slight_smile:
Including Methods, Windows and Tabs.
It meet all the requirements as listed in this thread and in forums in general.

The code can easily be read and understood by others, it’s clear, it’s fast to code, fast to find errors and different part of the code.
I have many years experience of coding on the web, but this is my first project in Xojo, as a stand alone application.
Naming is always important… But in Xojo all become very confusing. Now, I can name things the same, just with the different letter depending on where the code is located.

I don’t know how you (other programmers) name buttons, fields and lists, but using such method I can easily find a certain place for a special line or a simple word. Very neat! I post these things in case I can inspire others! It’s all!

The pictures speak for themselves! :slight_smile:

  1. The map, made in a PowerPoint look-a-like software.

  2. All Windows.

  3. Methods used in the Window.

Can a view become more self-explanatory!? For me, this is good enough!
4) Part of code.