Do you like to get statistics on your code?

That’s the right word. I get it.

ok thank you, the main thing is that it is expected :slight_smile:

Okay, that was a bug I had already fixed last month but the fix got lost due to me developing in two places and forgetting to submit the change to version control before I left. Gladly, I could merge the changes into Arbed (by using Arbed’s merge feature, of course), and I plan to issue a b19 later tonight.

It opens and the script runs fine for me.

OSX 10.8.5

And I just found out I have about 10% more comments than I do actual code lines.

Sorry for the delay. I was unable to quit with a window open, and then also after I closed the window. I’ll be back in the office in about 9 hours, and will try to duplicate on my dev machine then. Oh, and yes; it was with b18.

Peter, before you do any reproducing attempts, please open Arbed’s Preferences and check the “Enable Debug Messages”. That’ll create a log file on the desktop which will report when it closes a window or wants to quit. See if it says that it’s quitting, and when it says that it’s closing windows. It also reports all still-open windows. You may have to close and re-open the text file after every step to see it updated unless you’re using an editor that reloads the file automatically, such as BBEdit (and TextWrangler as well, I assume).

Then watch the output when you close a window or quit. Does it report the action? Especially if you press Cmd-Q and the app doesn’t quit - do you see a “quitting app now” message then?

In fact, please use this b18.2 version which adds some more debug output and adds a dedicated FileQuit-Handler, overriding Xojo’s default:

So, to reproduce the issue, try both ways:

  1. Auto-Quit by closing all windows.
  2. If the app remains running, try quitting with Cmd-Q or use the Quit menu. This calls the quit command now and might work better. In any case, I’d like to know what action results in what log output. Of course, I’m only interested in that if the app fails to auto-quit, otherwise everything works as expected.


I don’t have a lot of time at the moment to continue testing. But so far, after about 30 minutes, I have not been able to reproduce the problem with either b18 or b18.2.

I’ll try to keep banging on it later today, and let you know the results, Thomas.

Thanks, Peter. If you don’t find it, I’m happy to release 1.7 over the weekend :slight_smile:

No luck so far. Hopefully, you’ve fixed it, and if not, it seems rare enough not to be a big problem…

The link appears to be broken. Please fix this.

The link you refer to was for a beta release of Arbed 1.7. Since 1.7 has been released since, I think it’s normal that the link to the beta doesn’t work anymore. Please just go to the website to download Arbed.

The statistics script link’s broken, though - I can’t see how to find the stats in Arbed without the Statistics.arbs script…?

Yes, Like I said beta link. Download Arbed, install it and look in the scripts folder.
There you’ll find Statistics.arbs

its 404!

What is? the link I posted? It works here.
I tried all three the Arbed Downloads (Mac, Windows, Linux) on that page and they all work for me.
So what exactly isn’t working.
The statistics.arbs file is part of that download.
Am I missing something?

When you use the pbsw_listbox classes, Arbed fails loading the project.

Okay, that pbsw_listbox thing from 2004 was a bit of a surprise. It contains bad characters (NUL bytes) and Arbed refused to open it because of that.
I’ll soon release a new release 1.7.6 that only warns about the issue (twice, that’s currently unavoidable) but will then open the project.

For now, I suggest you go ahead and remove those NUL chars from the project, using the Xojo/RB IDE. Arbed does show you in which lines they appear, so you should be able to find them in the IDE.
(In fact, the NUL chars are all in “About” Notes, like this:

membership options <- right here there’s the NUL char. Delete that in all occurances of these Notes.

[quote=66546:@Thomas Tempelmann]Okay, that pbsw_listbox thing from 2004 was a bit of a surprise. It contains bad characters (NUL bytes) and Arbed refused to open it because of that.

Uh oh, my old code coming back to haunt me. I wonder how those NULs got in there, and if they are in any of my other old work. I’ll need to investigate and update at some point. So much to do, so little time…

This NUL issue happened frequently with older IDEs, but I haven’t seen it happen since 2012 any more.

Methods: 2428
Code lines: 16629 (9924 distinct ones)
Comment lines: 2831
Empty lines: 3857
Total lines: 23317

My project is taking me a while but it will be worth it in the end.