Debug folder does not go away

Note for my own sanity (or if someone cares why this demo didn’t work on 2019r2 and later) The code was working but a button I added to the form to test this termination of the webkits wasn’t firing because of <https://xojo.com/issue/58757>, I have adjusted the demo linked above.

Still, this might not help you Joost but its worth a try :slight_smile:

Will try first thing Monday morning and let you know. Thank you for the great work you do for all of us Julian.

@JulianS
I’ve tested your code for killing the CefSubPorc processes in the close event of the window. At least in 2019R1.1 it works and seems to solve my problem by iterating and stopping these procs. Thank you !

This has started happening for me too! This was stopping me being able to work. Luckily that cefCleaner works for me. Thanks @JulianS.

Xojo guys, please reopen “46532 - debug exe is not deleted” as requested by Joost

if youre still using 2019r1.1 its not fixed there
its supposed to be fixed for newer versions
see 2019r3 release notes

@Norman Palardy Ah ok. I’m using 2019r2.

I’d at least update to 2019r2.1 :slight_smile:

This is still happening in 2019R3!

It seemed to be fixed for a bit but now it’s returned. Any ideas on why this has started happening? I’ve been using R2 since it came out with no problems but this started a few days ago. I thought the cefcleaner was a work around but that doesn’t always work either.

No idea

This is happening all the time now and I’m unable to work. Any suggestions about a workaround or how to kill the process that remains is very welcome.

I’ve raised a new case (https://xojo.com/issue/58816)>]Feedback Report 58816

The response to the feedback report was that it was likely to be something to do with my system setup. So I tried turning off my virus protection, Malware Bytes 4.0.4 and that seems to have sorted it. I’ve turned the virus protection back on and things are still working.

So there does appear to be some interaction between Malware Bytes and Xojo.

cefCleaner did not work for me (Windows 10, Xojo v 2019 1.1). But turning off Malwarebytes finally allowed me to delete the debug folders.

@David Graham I moved away from Malwarebytes eventually. I had to reboot every morning to allow me to delete the debug folder and I tried everything I could think to stop Malware from interfering.

I’m now using Avast Premium with no issues.

Thanks Jim for pointing out where my problem might be. Fortunately I have retired, and last weekend was the first time I had used Xojo in a couple of years. My old job had asked me to modify my old code. So I can live with turning off Malware occasionally. Now I Just have to remember what the problem is if I run into the problem again.

Is there a way, in Windows, to over ride a lock from another app? In this case, from the Xojo IDE. Even when closed, Windows still keeps a lock on it until the PC is rebooted.

Tim

That seems really odd
If you open activity monitor is the IDE perhaps still running and only has a TrayItem open ?
There’s an option under Edit > Options > When Closing Last Window
If its set to “Keep Xojo Running” there will be a Xojo process running and an item in the tray where you could open a new project etc

its one more avenue to check to see if thats what holds that item
I cant think of any other reason it would IF the Xojo process completely exits as tha twould seem to be a huge bug in Windows

Hi Norman,

There is no Xojo icon in the system tray. I’ve never seen one there and just checked it is not there now either. BTW, I am using 2019 R1.1. But the same thing can happen in 2017 R3 too.

Tim

This was just a wild assed guess about what might be causing it
If you dig into the debug folder whats in there ?
That should be whatever items are being held and cant be deleted which might offer some clues (for any version this happens in)

Its the main exe file that is locked. Says I need admin approval, which I am an admin…

Even with the IDE off