DateTime control

Hi All,

Wondering if someone can help with an annoying issue. When I use the DateTimePicker, I don’t seem to be able to click into it. The only way I can access it is by tabbing in, then it lands on the day and I have to use arrows to get to month year etc. Is there a “switch” or option of some sort that I have to set to be able to choose it with the mouse? I have allow Tab Stop set.

Any help appreciated,

A good idea will be to share:

a. your platform/version name (Linux, macOS, Windows)
b. your Xojo version #,
c. You have done that in an empty project and get the same result … (not just tested in your current project)

My apologies, I program in macOS. Latest version and latest version of xojo.

Haven’t tested in an empty project but use the control multiple times on multiple windows in 5 projects I work on and same result in all.


Hi @Barry_Sidebottom

May you file a bug case about this, please?

Thank you!

Happy to but just a hobby programmer and have never done that. Can you instruct how?


Hi @Barry_Sidebottom,

Can you instruct how?

Sure! I think you’ll find this forum announce enlighting enough: Improving Feedback

Quick followup. After a bit of testing I have found it only appears to happen if you have more than 1 DateTime Control on a window.


So I am new to this issue reporting and I did as you asked and I have received an email stating that you have closed the issue. What does this mean? Is there a fix, if so what is it?

What happens now?


The email should tell you what actions were taken or comments left, but you can always go to the report and read what’s happened using the link from the email or directly.

In this case, the issue was closed because it has been fixed for a future release.

1 Like

I think you are talking about issue #68847

The case is marked Fixed and you should see the fix in a future version of Xojo.

Edit: I think the ‘Needs Review’ label should be removed



And the “Needs Review” label has been removed :slightly_smiling_face:

Thank you for pointing it!


Thanks for that. The email simply had “Issue was closed by Javier Menendez”. There was nothing else. No note of actions being taken etc.

All good, I’ll wait for the next update.



Correct, the email is only created with some actions, in this case, ‘closed’. If you follow the link then you can see all the information since you reported it:

I guess labels (added/removed) and assignments do not trigger an email, only the ‘closed’ sent an email. I don’t know the Issues system maybe there is an option to add a comment to the ‘closed’ action that can be added to the email? Something like ‘this Issue was closed because it was fixed’ could be really helpful.