2021r3 how do I debug what's triggering WebSession.InterruptionMessage?

which browser did you test?

@DerkJ do you have a proxy configuration that doesn’t give you disconnection issues?

i use lifeboat and NEVER had such issues using 2021R3 builds.
But i have a debian system (not ubuntu), i’m not sure but maybe it’s a memory issue? or something else?

Atleast Safari, Chrome, Brave don’t have such issues. Also no customer has ever complaint about such.

1 Like

In my case I use both Brave and Edge for testing, but I don’t think it’s a browser issue. Basically, I’ve encountered 3 problems:

Problem #1:

Failed to load resource: net::ERR_INCOMPLETE_CHUNKED_ENCODING

To try to solve it I increased DeflateBufferSize to avoid chunked but anyway after a while if the buffer is full the same problem comes back. Then I set SetEnv downgrade-1.0 1 on apache because in http1.0 in this version there is no chunked. Doing so I had no more errors in the browser console.

Problem #2:

[proxy_http:error] [pid 1051:tid 140063488853760] (70007)The specified timeout has expired: [client x.x.x.x:59595] AH01110: error reading response, referer:

I don’t understand why but with r3 the proxy timeout throws out my connection even while using the web app. I solved it by increasing the ProxyTimeout. I don’t have that message in the logs anymore

Problem #3:

Failed to load resource: net::ERR_CONNECTION_CLOSED

I don’t know how to solve this one, I get session disconnection and in the logs/console browser I don’t get any useful information to trace the problem.

In all three cases I can’t find a common cause. It happens at different times, with different timing, in different sections of the program.

I’ve also tried disabling startKeepAliveTimer and stopKeepAliveTime in the xojo framework, but nothing seems to have changed. I think something else changed under the hood in r3 but it’s not in the release notes.

@Greg_O_Lone Can you recommend any configuration? server timeout, web app timeout etc?

Edit: For example now on firefox it gave me this error:
7C8369B9238AEC346C99B3E3ADCB21A276020E3C0F4944287E404473BBF258F2/comm/serverevent was interrupted while loading the page. Xojo.js:6:21007

1 Like

Customers are using Chrome from what I remember.
I however tested with Edge, Chrome and Firefox. The disconnection happens in all of them.
This is not a browser/extensions/etc. issue.
It is simply a problem when running webapps behind proxy servers (nginx in my case or apache), related to Xojo’s new serverevent function (i’m pointing to this event because this is what I see in error logs and browser console).

ServerEvent is not new, nor is it ours. It’s an HTML protocol used by browsers for pushing content to which we first added to the framework in Web 1.0.


I didn’t say it was new. Simply the disconnection happens there. Almost always as you can see in the screenshot preceded and followed by the ping. In addition I don’t understand why the ping triggers twice. It seems as if the request is interrupted to respond to the ping? Of all that I wrote in the previous post could you give me your point of view @Greg_O_Lone ?

Just booked a xojo cloud Server.

Same error

https://66679.xojocloud.net/ (Build with 2021R3)

(Build with 2021R2.1 works)

Edit: added Build Infos

Please reference that in a Feedback case for this issue.

I did

Thank you.

7 days have passed and still no official word about this mega-issue… nice


This is a known bug. Try recompiling with a previous version of Xojo. There should be a fix soon hopefully.

Are they seriously going to make us wait for the fix, `till the next version release? I mean, this isn’t a minor bug that can be avoided… Apparently it was fixed in Nov 29th, yet 7 days later still no patch?

It is actively being worked on. We can expect the fix very soon I would venture to guess.

I have never seen a “patch” release from Xojo. They do point releases (3.1 maybe) or new releases.

Looks like 2021 r3.1 released today. Can anyone with the issue confirm it is resolved by this release? It’s in the release notes as fixed. I’m about to start a web project so interested to see before I start working on it in 3.1

It seems so. I’ve recompiled the web app that started all this, uploaded it and so far, no phone calls from my clients, seems stable :slight_smile: (30 min. uptime so far)


Great news!