Getting fully black windows at launch, how to avoid?

  1. 4 days ago

    Thomas T

    Jun 29 Testers, Xojo Pro Europe (Germany, Munich)

    Has someone noticed that, either when building for 64 bit, or maybe just since a recent Xojo version, programs briefly show a window that's entirely black? Looks quite ugly.

    Any idea why this happens and how to prevent this? And no, I do not have a black background set for those windows.

  2. Paul L

    Jun 29 Testers Toronto

    I see the same thing and was wondering what the issue was.

    I have a suspension it gets worse if there is a lot of background blocking code in the open event, but I have not done enough testing.

  3. Thomas T

    Jun 29 Testers, Xojo Pro Europe (Germany, Munich)

    Thanks for confirming.

    Yes, it seems to me that it's happening whenever the paint even is delayed but the background got already cleared for a redraw. Somehow, the background then gets filled with black even though it clearly shouldn't. But also, when I run the same app build by an older IDE, I get all my controls drawn even if I block the main thread during opening of the window. So, something definitely goes wrong there lately.

  4. Sam R

    Jun 29 Testers, Xojo Pro, Third Party Store Hengchun, Pingtung, Taiwan

    Steps I use to solve this.

    1. On open, hide the window.
    2. Perform your set-up.
    3. Use calllater to show it... later.

    Although I haven't tested this on macOS BS yet, a machine capable of running it should be here today, so wish me luck.

or Sign Up to reply!