Xcode 11 vs Xojo

  1. 2 months ago

    Xiangqun Z

    Jun 18 Pre-Release Testers, Xojo Pro New York, NY

    Hi there!

    Just installed xcode 11 beta due to the fact that I have iOS 13 beta on my iPhone. However, after I installed XCode 11, it became impossible for Xojo to get simulator list. The "simulator device" list is just empty and nothing can be clicked on. When clicking on "Run", it says "Trying to run an iOS project with no iOS devices configured". I know this happened on previous new Xcode version s, so I don't know if there is a workaround for this.

    Tried to change the Command Line Tools as stated in https://forum.xojo.com/30570-unable-to-run-ios-project/0 to the stable 10.2.1 version (which worked fine before I installed XCode 11 beta), but it was no use.
    Also, based on https://forum.xojo.com/53395-ios-app-issues-xojo-version-vs-xcode-version/0 , it seems this is a hard question. I don't think I can reinstall the whole system since I have other runtime environments for all kinds of other development.

    Therefore, I wonder if it is possible to have an upgrade on Xojo ASAP... Did not purchase Xojo license yet (I anticipated to do that after I totally finished my development on this project and start building). However, if a beta release of Xojo can fix this problem, I will definitely buy a license at once. Workaround is also fine for me.

    Any help would be appreciated :)

  2. Dave S

    Jun 18 San Diego, California USA

    each version of "Xojo for iOS" requires a specific version of Xcode.

    And doubt Xojo will release an XCode11 compatible version until Xcode11 is publicly released (ie. no longer a Beta)

  3. Alyssa F

    Jun 18 Xojo Inc Portland, Oregon

    Xojo currently supports xcode 9 and 10. To quote one of our engineers @Greg OLone from an earlier message along these lines “Apple’s NDA clearly states that you may not discuss betas with anyone who is not part of the beta program. Since that cannot be guaranteed for the entire membership of our forum, it shouldn’t be going on at all…it’s fine to send us private messages, but we really won’t be looking at 10.15 bugs until Apple releases Developer Beta 3 or 4 since that’s when the big regressions usually settle down…if you don’t want to risk Apple cancelling your developer account don’t openly discuss products that they’ve got an NDA on until Apple tells you otherwise.

  4. Xiangqun Z

    Jun 18 Pre-Release Testers, Xojo Pro New York, NY

    Thanks for the reply... However I am still running 10.14.5 (not 10.15) on my MacBook Pro.
    Just tried to reinstall XCode 10.2.1, but it was no luck.
    To comply with Apple NDA, I think I will just send private messages with Alyssa.

    Thanks again!

or Sign Up to reply!