RS232 communication problem

  1. 5 months ago
    Edited 5 months ago

    Hi everyone, I re-open another ticket because I am unable to solve my problem. I'm working with my hardware and Xojo (creating a small program for reading the serial) and I'm finding difficulties. I followed a video on Youtube and some documentation, but when I try to read the data on my device, the screen shows some strings, others don't. In practice, with the button I send a command to the device and he answers me. I don't have this problem with Hercules, but here it is. Can someone help me?

    -image-

    if InStr(me.LookAhead(Encodings.ASCII), chr(13)+chr(10)) > 0 then
      TextArea1.text = TextArea1.Text + Me.Readall(Encodings.ASCII)
    end if
  2. Maurizio R

    Jun 11 Pre-Release Testers, Xojo Pro
    Edited 5 months ago

    Hi Mario,
    I've seen your posts in this and other threads.
    It would be very useful if you post in some public place your full project to review and more info on how the device is supposed to send data on the wire.

    From the code you are posting here you are supposing the device sends data blocks delimited with the CR/LF chars but in another post you seems not so sure the device operates this way.

    In another piece of code you posted in another thread there is something that seems you are not setting the serial parameters (baudrate and so on) as it should be.

    Please post as much information as you can so we can help you.

    Regards.

or Sign Up to reply!