Failure to compile

  1. 4 weeks ago

    Certain versions of Xojo can't seem to compile my code. I don't get any syntax or Nil Object Exceptions it just plain fails to compile for some unknown reason. It works fine on Xojo 2016r2 and some newer versions but not no Xojo 2018r4 nor 2019r1. Not sure what to do or how to solve it since it won't tell me why it fails.

  2. Jason K

    Apr 23 Pre-Release Testers

    Submit a feedback case and privately attach your project so Xojo can look at it. We can’t help you without more information

  3. Greg O

    Apr 24 Xojo Inc

    @Charles F Certain versions of Xojo can't seem to compile my code. I don't get any syntax or Nil Object Exceptions it just plain fails to compile for some unknown reason. It works fine on Xojo 2016r2 and some newer versions but not no Xojo 2018r4 nor 2019r1. Not sure what to do or how to solve it since it won't tell me why it fails.

    Please contact us directly through hello@xojo.com so we can get this issue resolved.

  4. 6 days ago

    Leonidas B

    May 13 Macaé, RJ, Brazil

    Hello @Charles F and @Greg OLone !

    Any development on this?

    I'm experiencing some issues when trying to compile a Linux web app using a Windows 10 machine.

    It takes "forever" to compile, about 12 min, and sometimes it does not compile at all. It silently fails to compile. On top of that, the app sometimes breaks when doing some variable comparisons...

  5. Robin L

    May 14 Xojo Inc Europe (Germany, Rehlingen)

    @Leonidas,
    I have added a sample project containing your (incomplete) code fragment to your Feedback case.
    You can modify this sample project to replicate the issue, or supply your own project (privately if you wish).

  6. Leonidas B

    May 14 Macaé, RJ, Brazil

    Hello @Robin L !

    I adapted and teste your code. It works. Will take a deeper look into what I have done previously. I also have sent you the code through Feedback.

    By the way, I find your logo ("NOT APPLE") awesome! I always felt a little sidetracked as a Windows user amongst Apple fans.

    I'm compiling my original code in XOJO 2019r1. It is taking a long time. 10 minutes and counting! As soon as it works I'll tell what happened. It took about 15 min to first compile. Not working as expected. I will add more info to the Feedback Case 55661.

  7. 5 days ago

    Greg O

    May 14 Xojo Inc

    @LeonidasBrasileiro
    I’m curious what your compile settings are. I’m assuming 64-bit, but do you also have it set to Moderate or Aggressive? If so, try Default while you are debugging. It’ll save you lots of time.

    I only say this because even the IDE doesn’t take 25 minutes on Default.

  8. Leonidas B

    May 14 Macaé, RJ, Brazil

    Hello @Greg OLone !

    Thanks for your reply and observations.

    I have been working very long hours on this... with a ton of anxiety that are not that helpful.

    I had it set to Agressive. Putting back to Default now. Thanks.

    The web app is becoming rather big and complex. Thank God customers are asking for new features and so, and I'm attending them whenever I see a good fit.

    I'm quite happy with what I achieved and what I have learned along the way and how I can help my fellow Health and Safety professionals and make a profit with it.

    You know, I'm a Mechanical and Safety Engineer, not that well trained in programming, databases, servers, OS´s and all the surrounding things (HTML, CSS, PHP, Javascript, Python, ...) that a web app needs. I had to study a lot to put it all together and overcome my lack of knowledge while also improving my skills as entrepreneur...

    One of my wild thoughts when things are not gong according to plan is that the compilation might get corrupted due to intensive processing... I see my old notebook CPU, Memory and Disk gauges work furiously while building the app. I'm not using a high end computer to do it. Is it something to be considered?

  9. Greg O

    May 14 Xojo Inc

    @LeonidasBrasileiro One of my wild thoughts when things are not gong according to plan is that the compilation might get corrupted due to intensive processing... I see my old notebook CPU, Memory and Disk gauges work furiously while building the app. I'm not using a high end computer to do it. Is it something to be considered?

    I doubt that the “intensive processing” would cause corruption. Now, a bad memory chip could if it’s only used when compiling.

or Sign Up to reply!