Requisito de XCode para aplicaciones IOS

  1. 2 months ago

    Óscar J

    Nov 23 Pre-Release Testers, Xojo Pro Madrid, Spain

    Hola.

    He intentado ejecutar una aplicación IOS de las que vienen de ejemplo y veo que no se está habilitando el botón de Play. Al colocar el cursor sobre el icono, un tooltip me informa de que necesito XCode y sus correspondientes herramientas, pero yo ya tengo XCode 10.1 instalado... ¿Solo se puede utilizar una versión específica de Xcode, imagino que más antigua, o es que hace falta configurar algún parámetro oculto en algún fichero de configuración?

    Óscar.

  2. Javier M

    Nov 23 Pre-Release Testers, Xojo Pro AprendeXojo - Europe, Spain

    Hola Oscar,

    ¿Qué versión y Edición de Xojo estás utilizando?

    En la información de Requerimientos del Sistema indican lo siguiente:

    "In order to work on iOS projects, you must be using Xojo on at least macOS 10.12 and later with Xcode 9.x (required for iOS Simulator). macOS Mojave requires Xojo 2018r3 or later."

    Javier

  3. Óscar J

    Nov 23 Pre-Release Testers, Xojo Pro Madrid, Spain

    Hola, Javier.

    Estoy utilizando Xojo 2018r3 con licencia Desktop en una macOS Mojave. Sé que no puedo desplegar, pero debería permitirme ejecutar en el emulador, ¿no?

    Óscar.

  4. Javier M

    Nov 23 Pre-Release Testers, Xojo Pro AprendeXojo - Europe, Spain

    ¿Has instalado las herramientas de línea de comandos en Xcode 10.x?

    Igual por ahí podría ir el problema…

    Javier

  5. Óscar J

    Nov 23 Pre-Release Testers, Xojo Pro Madrid, Spain

    Mmmm... Si no son las que instala XCode cuando se inicia por primera vez, es posible que ese sea el problema. Gracias por la indicación.

  6. Óscar J

    Nov 23 Pre-Release Testers, Xojo Pro Madrid, Spain

    Efectivamente, tenía que instalar las herramientas de línea de comandos y no sólo eso, también habilitarlas desde las preferencias del XCode.

    Oscar.

or Sign Up to reply!